php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58204 Segmentation Fault
Submitted: 2008-05-28 16:32 UTC Modified: 2009-03-06 01:09 UTC
From: adam at morrison-ind dot com Assigned:
Status: Closed Package: PDO_INFORMIX (PECL)
PHP Version: 5.2.5 OS: openSUSE 10.3
Private report: No CVE-ID: None
 [2008-05-28 16:32 UTC] adam at morrison-ind dot com
Description:
------------
When executing a query occasionally (~30% of the time) a Segmentation Fault occurs.

Expected result:
----------------
Valid result.

Actual result:
--------------
Informix SDK 3.50.UC1
apache2-2.2.4-70.4
php5-5.2.5-8.1
PDO_INFORMIX 1.2.0

Core was generated by `/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf'.
Program terminated with signal 11, Segmentation fault.
#0  0xb466ea3c in _OdbcCancel () from /opt/informix/lib/cli/libifcli.so
(gdb) bt full
#0  0xb466ea3c in _OdbcCancel () from /opt/informix/lib/cli/libifcli.so
No symbol table info available.
#1  0xb466ea12 in SQLCancel () from /opt/informix/lib/cli/libifcli.so
No symbol table info available.
#2  0xb486b948 in informix_stmt_dtor (stmt=0x804d4df8) at /tmp/PDO_INFORMIX-1.2.0/informix_statement.c:684
No locals.
#3  0xb6c31f11 in free_statement (stmt=0x804d4df8) at /tmp/pear/temp/PDO/pdo_stmt.c:2200
No locals.
#4  0xb6c3209d in pdo_dbstmt_free_storage (stmt=0x804d4df8) at /tmp/pear/temp/PDO/pdo_stmt.c:2245
No locals.
#5  0xb78d6240 in zend_objects_store_free_object_storage () from /usr/lib/apache2/mod_php5.so
No symbol table info available.
#6  0xb78a9d03 in shutdown_executor () from /usr/lib/apache2/mod_php5.so
No symbol table info available.
#7  0xb78b713f in zend_deactivate () from /usr/lib/apache2/mod_php5.so
No symbol table info available.
#8  0xb786dfca in php_request_shutdown () from /usr/lib/apache2/mod_php5.so
No symbol table info available.
#9  0xb793d13c in php_handler () from /usr/lib/apache2/mod_php5.so
No symbol table info available.
#10 0x8003280d in ap_run_handler () from /usr/sbin/httpd2
No symbol table info available.
#11 0x80036277 in ap_invoke_handler () from /usr/sbin/httpd2
No symbol table info available.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-28 16:49 UTC] adam at morrison-ind dot com
Setting the database connection variable to null ($ds = null) after processing avoids the seg. fault.
 [2008-05-29 08:17 UTC] opendev at us dot ibm dot com
Hi Adam,

I would like to know few things from you:
1. After looking onto the logs, it looks like that you are running the application on web server. Can you able to reproduce the same situation in standalone command line script.
2. In the application, are you closing connection every time or re-using it for further operations?
3. Can you send a the sample code by which you are getting this segv because I am not able to reproduce it?

Thanks.
 [2009-03-06 01:09 UTC] abhargav at in dot ibm dot com
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 03:01:25 2019 UTC