php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #58203 php function svn_status not work expect and halt up
Submitted: 2008-05-27 12:20 UTC Modified: 2008-07-07 19:35 UTC
From: eric at myprojects dot srhost dot info Assigned:
Status: Closed Package: svn (PECL)
PHP Version: 5.1.6 OS: WIN2000
Private report: No CVE-ID: None
 [2008-05-27 12:20 UTC] eric at myprojects dot srhost dot info
Description:
------------
It seems that the svn_status thrid parameter not work as expected.

(complied the source code with vc++ 6.0 with sp6 + default windows sdk)

Reproduce code:
---------------
$result = svn_status('r:/projects/wc/phpbb3', TRUE, TRUE);

Expected result:
----------------
R:\Projects\wc\phpbb3>svn status -v
                3        3 aderic       .
               15       15 aderic       viewtopic.php
                7        7 aderic       language
                7        7 aderic       language\en
                7        7 aderic       language\en\acp
                7        7 aderic       language\en\cash_lang.php
               14       14 aderic       styles
               14       14 aderic       styles\prosilver
               14       14 aderic       styles\prosilver\template
               22       22 aderic       styles\prosilver\template\viewtopic_body.html
               14       14 aderic       styles\prosilver\template\cash_body.html
               14       14 aderic       cash.php
                3        3 aderic       includes
                6        6 aderic       includes\cash_installer_sql.php
               11       11 aderic       includes\class_cash_admin.php
               14       14 aderic       includes\class_cash.php
!               5        5 aderic       includes\cash_setting.inc.php
               13       13 aderic       includes\cash_settings.inc.php
               16       16 aderic       cash2_no_long_need.php

Actual result:
--------------
NONE

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-27 12:33 UTC] scottmac@php.net
The documentation is out of date there. There is now only 2 parameters, the 2nd being flags.

svn_status($path, SVN_ALL);
 [2008-05-27 13:43 UTC] eric at myprojects dot srhost dot info
Thanks scottmac,

I have found the constants and soon will testing it.
 [2008-05-28 01:54 UTC] eric at myprojects dot srhost dot info
I have tested that these two work.

SVN_ALL | SVN_NON_RECURSIVE

But with these does't show anything.
Am I do any wrong ?

SVN_ALL | SVN_NON_RECURSIVE | SVN_SHOW_UPDATES
SVN_ALL | SVN_SHOW_UPDATES
 [2008-06-30 20:50 UTC] scottmac@php.net
I can't reproduce this on Linux, is this still happening on Windows with 0.4.1?

SVN_SHOW_UPDATES tells the svn_status to check with the repository for the latest information.
 [2008-07-02 09:51 UTC] eric at myprojects dot srhost dot info
Hi, scottmac,

It is work now !

But I need more few days to do a full test.



Eric,
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 08:01:25 2019 UTC