php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58184 Segmentation fault
Submitted: 2008-04-30 05:33 UTC Modified: 2008-04-30 07:07 UTC
From: toni dot ramos at gmail dot com Assigned:
Status: Closed Package: mqseries (PECL)
PHP Version: 5.2.5 OS: openSuSE
Private report: No CVE-ID: None
 [2008-04-30 05:33 UTC] toni dot ramos at gmail dot com
Description:
------------
When comp_code != 0 a segmentation fault is made after calling mqseries functions. Ex: when there are no messages in the queue the mqseries_get() crashes with segfault.

Reproduce code:
---------------
    mqseries_get($conn, $obj, $mdg, $gmo, 255, $msg, $data_length, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("GET CompCode:%d Reason:%d <br>", $comp_code, $reason);
    }

Expected result:
----------------
GET CompCode:2 Reason:2033

Actual result:
--------------
Segmantation fault
# 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-30 06:46 UTC] toni dot ramos at gmail dot com
Sorry!

The problem is in the "mqseries_strerror($reason)" function called after.

i'll investigate.
 [2008-04-30 07:07 UTC] toni dot ramos at gmail dot com
closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Aug 20 19:01:29 2019 UTC