php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57980 db2_pconnect unable to recover from an application force
Submitted: 2007-12-27 11:57 UTC Modified: 2010-09-07 15:32 UTC
From: matthewv at ca dot ibm dot com Assigned:
Status: Closed Package: ibm_db2 (PECL)
PHP Version: 5.2.1 OS: Windows XP, Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: matthewv at ca dot ibm dot com
New email:
PHP Version: OS:

 

 [2007-12-27 11:57 UTC] matthewv at ca dot ibm dot com
Description:
------------
Should be easy to reproduce. 

- On an Apache web server. An application connects to a database (I am using a local sample database) using db2_pconnect.

- The page is returned.

- the httpd database connection is force from the database. 

- The user request a new page. 


When the user request a new page, The connection looks intact when we come back and get the connection using db2_pconnect. But all statements return nothing, no SQL state is returned or error messages.

doing a db2_close() on the valid resource ID and then reconnecting dose not help and returns a valid looking connection resource ID no SQL State or error messages are returned. 




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-18 10:30 UTC] m dot van at isecara dot ca
Is there an update on the status of this bug?
 [2009-03-18 11:33 UTC] abhargav at in dot ibm dot com
Hi,

Did you tried v1.8.0 or higher of IBM_DB2? There are lot many changes in this function.

Let me know if it does not works.

Regards,
Ambrish Bhargava
 [2009-04-07 08:58 UTC] matthewv at ca dot ibm dot com
As of 1.8.2 this bug is not fixed
 [2009-04-08 10:27 UTC] abhargav at in dot ibm dot com
Hi,

Can you send me (mail me) the same scripts for this problem?

Regards,
Ambrish Bhargava
 [2010-09-07 15:32 UTC] abhargav at in dot ibm dot com
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/ibm_db2

Regards,
Ambrish Bhargava
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Oct 23 23:01:30 2019 UTC