php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57861 crack_opendict() fails
Submitted: 2007-10-02 23:58 UTC Modified: 2008-07-17 06:13 UTC
From: lammy96424 at yahoo dot co dot jp Assigned:
Status: Closed Package: crack (PECL)
PHP Version: 4.3.9 OS: CentOS release 4.5 (Final)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: lammy96424 at yahoo dot co dot jp
New email:
PHP Version: OS:

 

 [2007-10-02 23:58 UTC] lammy96424 at yahoo dot co dot jp
Description:
------------
crack_opendict() fails.

There is the dictionary file.

[As a result of ls command]
# ls -1 /usr/lib64/ | grep cracklib_dict
cracklib_dict.hwm
cracklib_dict.pwd
cracklib_dict.pwi

Reproduce code:
---------------
if( !$dict = crack_opendict("/usr/lib64/cracklib_dict") )$errnum = 200; //can't open dictionary file.

Expected result:
----------------
true returns.

Actual result:
--------------
Warning: Could not open crack dictionary: /usr/lib64/cracklib_dict in /var/www/mail/cracktest.php on line 28


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-17 06:13 UTC] tony at daylessday dot org
This is likely to be duplicate of #9710.
 [2015-04-21 20:21 UTC] gpullis at co dot broome dot ny dot us
I'm having this problem with Oracle Linux 6.5 (equivilent to CentOS 6.5) with PHP version 5.3.3.

I'm using the same dictionary path as in the original bug report.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 05:03:35 2021 UTC