php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57477 probleme name in upgrade
Submitted: 2007-01-13 18:09 UTC Modified: 2007-01-15 23:59 UTC
From: vistoon at symuon dot com Assigned:
Status: Closed Package: SCA_SDO (PECL)
PHP Version: 5.1.6 OS: linux (kubuntu)
Private report: No CVE-ID: None
 [2007-01-13 18:09 UTC] vistoon at symuon dot com
Description:
------------
it seems that in Exception.php, SDO_Exception it's an extend of SDO_DAS_Relional_Exception. But it can't found it.

is it a special thing to place in path_include of php.ini ?

Reproduce code:
---------------
<?php
    require_once 'SDO/DAS/Relational.php';
?>

Expected result:
----------------
nothing visual; 

Actual result:
--------------
Fatal error: Class 'SDO_Exception' not found in /usr/share/php/SDO/DAS/Relational/Exception.php on line 30

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-15 05:05 UTC] simonslaws at googlemail dot com
Hi 

Can you tell use how you installed PHP and the SCA_SDO extension?

SDO_Exception is part of the native PECL SCA_SDO extension so maybe the extension is not being loaded properly. Can you check that the extension is enabled

 * php -m should show you that the sdo extension is enabled
 * if it isn't add the following line to php.ini
   extension=sdo.so

also check that php.ini is set to allow the sdo library (sdo.so on linux) to be loaded correctly 
  
 * look at the line "extension_dir" and make sure that it points to wherever you have sdo.do installed

Hope that helps

Simon
 [2007-01-15 09:43 UTC] vistoon at symuon dot com
yep, thanks.

i found the problem.
I've the old sdo for my application, and i want upgrade but nothing so i decided to install put i will have this message
#>pecl install sdo
pear/sca_sdo conflicts with package "pear/sdo", downloaded version is 1.0.4
pear/SDO cannot be installed, conflicts with installed packages
No valid packages found
install failed


so as i see in the net, guy use pear instead pecl, i tape
#>pear install sdo
and the installation was done (download of the package etc...) but my application was break with the message of this bug.

After i read your message, i notice the name was'nt sdo but sca_sdo, so i tape:
#>pecl clear-cache
#>pecl install sca_sdo
and miracle, it's done !!!
(when i run my application which use sdo, i see assert's error in relational.php, but it's another problem...)

Thank a lot, you can closed this ticket
 [2007-01-15 23:59 UTC] vistoon at symuon dot com
i closed this ticket. the problem has the just the name of the package. sca_sdo instead sdo (in previous package)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 00:01:26 2019 UTC