php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #57462 Need Subversion 1.4.x Support
Submitted: 2006-12-28 12:14 UTC Modified: 2008-04-14 02:12 UTC
From: mfn at outsch dot org Assigned: scottmac (profile)
Status: Closed Package: svn (PECL)
PHP Version: 5.2.0 RC4 OS: Windows
Private report: No CVE-ID: None
 [2006-12-28 12:14 UTC] mfn at outsch dot org
Description:
------------
Subversion 1.4 is not supported by the Windows binaries. So its impossible to access a working copy generated by Subversion 1.4.2. Perhaps it would be a good idea to compile 2 Versions. One with the old 1.3.2 Source an one with the new one.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-25 22:36 UTC] edwardzyang at thewritingpot dot com
See also http://pecl.php.net/bugs/bug.php?id=10628
 [2007-05-28 07:23 UTC] axel at kollmorgen dot net
you could work around this by creating (svnadmin create --pre-1.4-compatible) / converting a 1.4 to a pre-1.4-compatible repository [1].

or you could use the 1.4 compatible binary [2], which, after many hours and trial and error, i managed to build. using svn 1.4.3 and the latest source from cvs (so some bugs fixed after the 0.2 release should be fixed in there, too).

of course updating the svn libraries on pecl4wins build machine, as suggested by edwardzyang, would be the more favourable route. will follow up there.

hope that helps.

[1] http://svn.collab.net/repos/svn/trunk/notes/repos_upgrade_HOWTO
[2] http://www.sendspace.com/file/mrk1r9
 [2007-06-18 14:58 UTC] axel at kollmorgen dot net
the 1.4 binary at sendspace got removed because of lack of downloaders ... just in case anyone should still need it:

http://www.twango.com/channel/axk.dll

(i also added a php-5.2.3-apache-2.2 version)
 [2007-11-13 17:07 UTC] edwardzyang at thewritingpot dot com
I, too, have managed to get it to compile on Windows, so I'm good. I needed this patch to config.w32 to make it work, though (backwards compatible):

Index: config.w32
===================================================================
RCS file: /repository/pecl/svn/config.w32,v
retrieving revision 1.6
diff -u -r1.6 config.w32
--- config.w32	19 Apr 2006 23:35:01 -0000	1.6
+++ config.w32	13 Nov 2007 21:44:14 -0000
@@ -25,8 +25,10 @@
 			CHECK_LIB("intl3_svn.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr;" + PHP_SVN) &&
 			CHECK_LIB("libdb43.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr;" + PHP_SVN) &&
 			CHECK_LIB("libneon.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\neon;" + PHP_SVN) &&
-			CHECK_LIB("libapr.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr;" + PHP_SVN) &&
-			CHECK_LIB("libaprutil.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr-util;" + PHP_SVN) &&
+			(CHECK_LIB("libapr.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr;" + PHP_SVN) ||
+    CHECK_LIB("libapr-1.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr;" + PHP_SVN)) &&
+			(CHECK_LIB("libaprutil.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr-util;" + PHP_SVN) ||
+    CHECK_LIB("libaprutil-1.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr-util;" + PHP_SVN)) &&
 			CHECK_LIB("xml.lib", "svn", PHP_PHP_BUILD + "\\lib\\svn\\apr-util;" + PHP_SVN)
 			) {
 		EXTENSION("svn", "svn.c");
 [2007-11-13 17:09 UTC] edwardzyang at thewritingpot dot com
It looks like the patch got mangled. Posted here:

http://www.thewritingpot.com/scrap/config.w32.patch
 [2008-02-19 01:53 UTC] axel at kollmorgen dot net
jfyi: i uploaded windows binaries compiled with the newest php(5.2.5)/subversion(1.4.6)/php_svn(0.3/svn.c 1.46)/apache(2.2.8/2.0.63) versions to my google pages (twango doesn't support .zips anymore):

http://akollmorgen.googlepages.com/php_svn-5.2.5-1.4.6-0.3-1.46-2.2.zip (for apache 2.2.x)
http://akollmorgen.googlepages.com/php_svn-5.2.5-1.4.6-0.3-1.46-2.0.zip (for apache 2.0.x)

if anyone should need it ...
 [2008-04-08 19:58 UTC] spam at spam dot nl
Thanks, it took me a while to dind these downloads!
 [2008-04-13 13:27 UTC] vic at phpbb dot com
For future reference: this is also the only build which appears to work on Windows Vista. Previous builds available from php.net or (as far as I could find, during my two-weeks search) other sources all segfault or report access violations. Not to be confused with bug #12440, which did not apply to my install.

It would be great if this patch could be included in the main release of php_svn.

Vic D'Elfant
 [2008-04-13 13:31 UTC] scottmac@php.net
I've not had time to setup a new build machine for Windows, 
once I have i'll hopefully do it this week.
 [2008-04-14 02:12 UTC] alan at akbkhome dot com
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

fix looks pretty trivial, so I've added it for the time being.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 05:01:26 2019 UTC