php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57165 API=20050922, API=20060613 the two must match
Submitted: 2006-07-31 02:56 UTC Modified: 2007-12-08 05:35 UTC
From: this dot resume at gmail dot com Assigned:
Status: Closed Package: radius (PECL)
PHP Version: 5_1 CVS-2006-07-31 OS: Win XP 2002
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: this dot resume at gmail dot com
New email:
PHP Version: OS:

 

 [2006-07-31 02:56 UTC] this dot resume at gmail dot com
Description:
------------
Radius PECL made for PHP 5.1.2.2.
Apache 2.0.5.8

I read a bug report indicating that the pear installer can not install PECL modules on Windows OS, and that the .dll method is reccommended.  However, when I add the radius extension to php.ini and put php_radius.dll in c:\php\ext and then reset Apache, I get the message:

  PHP Startup: radius: Unable to initialize module
  Module compiled with module API=20050922, debug=0,   thread-safety=1
  PHP compiled with module API=20060613, debug=0,   thread-safety=1
  These options need to match.  

I believe the APIs are embedded in the code; that I might have to learn C, and Berkeley API and still might not be able to fix this problem.  I would very much like to install radius PECL onto my server because it is a dependancy to Auth_RADIUS PEAR.  

Reproduce code:
---------------
CLI:

pear install Auth_RADIUS
Did not download dependencies: pecl/radius, use --alldeps or --onlyreqdeps to do unload automatically
pear/Auth_RADIUS requires package "pear/radius <version >=1.2.4>
No valid packages found
install failed

pecl install radius
downloading radius-1.2.4.tgz ...
Starting to download radius-1.2.4/tgz (29,599 bytes)
.............done: 29,599 bytes
16 source files, building
ERROR: The DSP radius.dsp does not exist

php.ini:
extenstion=php_radius.dll


Expected result:
----------------
CLI:
I expected radius to install so that I could install Pear/Auth-Radius.


php.ini:
I expected the extension to load so that I could install Pear/Auth_RADIUS


Actual result:
--------------
Could not get pecl/radius to install on my computer using any technique imaginable.  Could not find any documentation regarding what the problem is, or how to solve it.

The Apache server works properly.  So the the PHP server, as well as all other currently allowed extensions.  

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-21 18:33 UTC] Shawnberney at raguiding dot net
I have run across the error code citing unable to initialize module compiled with module API 20050922... PHP compiled with module API=20060613...

I was attempting to install php_xsl.dll extension to a Windows XP, Apache 2.2, PHP 5.2 installation. All default installed extensions function properly. Any resolutions would be appreciated.

Shawn 
shawnberney@raguiding.net
 [2007-04-03 11:41 UTC] visser at terena dot nl
I had the same problem, API version mismatch.
I upgraded from Ubuntu Edgy to Feisty-Beta.
However, it turned out that some script was using /usr/bin/php-config, which was giving the config of the old php (5.1.4). The right one is /usr/bin/php-config5.
After removal of /usr/bin/php-config and making a symlink with that name to /usr/bin/php-config5 it worked.
I did:
- download source of radius-1.2.5.tar.gz
- unpack and run phpize5 (not!! phpize)
- ./configure && make

The resulting radius.so works fine in PHP-5.2.1.
However, for some strange reason pear would still think that radius.so was not installed, so I used:

pear install --ignore-errors auth_radius

Then it was OK and I could authenticate again :)
 [2007-12-08 05:35 UTC] michael at bretterklieber dot com
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support/ as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

build problem no problem of the pecl itself
 [2010-01-17 21:32 UTC] malynetkeat at yahoo dot com
PHP Startup:PDO: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=1
PHP compiled with module API=20060613, debug=0, thread-safety=1
These options need to match
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 21:01:27 2020 UTC