php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57083 Unable to retrieve double/real values from DB2
Submitted: 2006-06-12 16:05 UTC Modified: 2006-11-27 08:32 UTC
From: simonslaws at googlemail dot com Assigned: slaws (profile)
Status: Closed Package: SCA_SDO (PECL)
PHP Version: 5.1.4 OS: Windows XP
Private report: No CVE-ID: None
 [2006-06-12 16:05 UTC] simonslaws at googlemail dot com
Description:
------------
PHP 5.1.4 
SDO 1.0.1
DB2 8.2FP12

Including columns of type double or real in the statement used to retrieve a data object (from a table with columns of those types) causes the statment to faile (silently) and zero rows to be returned

Reproduce code:
---------------
CREATE TABLE "SIMON"."ALLTYPE"  (
		  "AINTEGER" INTEGER,
		  "ADOUBLE" DOUBLE, ...

$stmt = "select ainteger, adouble from alltype";    
$root = $das->executeQuery($dbh, $stmt);
// fails

$stmt = "select ainteger from alltype";    
$root = $das->executeQuery($dbh, $stmt);
// succeeds

Expected result:
----------------
Avaialble rows to returned when requrested

Actual result:
--------------
No data returned when dould or real columns requested

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-28 11:48 UTC] simonslaws at googlemail dot com
The root cause of this is PDO_ODBC bug 7755 (http://pecl.php.net/bugs/bug.php?id=7755). I have suggested a fix for this so we just have to wait and see.
 [2006-11-27 07:15 UTC] cem@php.net
The PDO bug is fixed in 5.2
 [2006-11-27 08:32 UTC] simonslaws at googlemail dot com
Fixed in the PDO codebase for PHP 5.2
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 27 11:01:28 2019 UTC