php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56940 ibm_db2 uses slow CLI calls, which leads to 4x slowdown comparing to ext/odbc
Submitted: 2006-04-06 17:13 UTC Modified: 2006-07-19 11:33 UTC
From: tony2001@php.net Assigned: kraman (profile)
Status: Closed Package: ibm_db2 (PECL)
PHP Version: Irrelevant OS: Irrelevent
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tony2001@php.net
New email:
PHP Version: OS:

 

 [2006-04-06 17:13 UTC] tony2001@php.net
Description:
------------
ibm_db2 extension is 4x slower than ext/odbc because of slow CLI calls, which in turn prepare statement each time.
I don't know all the technical details, but the team asked me to report the bug, so they can keep track of this issue.

Reproduce code:
---------------
Looks like this can be reproduced with any script issuing any queries.

Expected result:
----------------
.

Actual result:
--------------
.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-19 11:33 UTC] kraman at gmail dot com
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 15 17:01:42 2019 UTC