php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56862 PHP Fatal error: Maximum execution time of 30 seconds exceeded
Submitted: 2006-02-27 05:48 UTC Modified: 2006-04-12 11:26 UTC
From: robertg2 at hope dot ac dot uk Assigned:
Status: Not a bug Package: oci8 (PECL)
PHP Version: 5.1.2 OS: Suse 10 - 32-bit
Private report: No CVE-ID: None
 [2006-02-27 05:48 UTC] robertg2 at hope dot ac dot uk
Description:
------------
Every so often (i.e. every month or so) some of our websites stop responding.  Looking at Apache 2's error_log reveals a number of the following errors:

PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /srv/www/htdocs/applicantday/include.php on line 60

(Line 60 corresponds to the oci_connect call).

Restarting Apache 2 does not resolve the issue.  Rebooting the machine does.  I'm currently using oci8 pecl from CVS from 2006-02-09.

This *looks* like a bug...?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-27 05:54 UTC] tony2001 at phpclub dot net
I've never seen such problem and I'm sure I'm unable to reproduce it.
So please try to give me some more info.
Are you connecting to a remote Oracle server or it's local for Apache?
What happens on the server side at that moment?
 [2006-02-27 06:39 UTC] robertg2 at hope dot ac dot uk
It's a remote Oracle server, i.e. Apache is not on the same box.

Looking at $ORACLE_HOME/network/log/listener.log there's no mention of any login attempts during this weekend for the Apache machine.
 [2006-02-27 07:36 UTC] tony2001 at phpclub dot net
Which client library are you using?
 [2006-02-27 08:11 UTC] robertg2 at hope dot ac dot uk
InstantClient 10.2.0.1
 [2006-02-27 08:18 UTC] tony2001 at phpclub dot net
Try to use gdb to see where exactly it freezes, maybe that would help to understand the problem.
 [2006-02-27 08:31 UTC] robertg2 at hope dot ac dot uk
I will try, but it might be a number of weeks - or even months - before the problem appears again.  In the meantime, you might want to change the status of this bug.
 [2006-02-27 08:33 UTC] tony2001 at phpclub dot net
Also, it would be good if you try to reproduce it on another server.
 [2006-04-05 14:35 UTC] robertg2 at hope dot ac dot uk
Rather irritatingly, the problem has yet to reoccur.
 [2006-04-12 11:26 UTC] tony2001 at phpclub dot net
After an investigation the problem seems to be in the Instant Client which freezes at some point when trying to connect to the non-working server.
There is nothing OCI8/PHP can do about it..
 [2013-02-13 18:40 UTC] krishna dot rajappa at gmail dot com
I know this comment is pretty late, but who knows! it might save someone from going bald.

There's an Oracle client bug that hits after server is up for 199 days and a server reboot would solve the issue. For folks who can't believe that a reboot would solve a 'client' library issue:
https://forums.oracle.com/forums/thread.jspa?messageID=4069511
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 14:01:25 2019 UTC