php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56636 Installation woes with autoconf/autoheader
Submitted: 2005-11-11 05:21 UTC Modified: 2006-02-24 02:06 UTC
From: steve at teamITS dot com Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 4.3.10 OS: FreeBSD 4.7-RELEASE-p28
Private report: No CVE-ID: None
 [2005-11-11 05:21 UTC] steve at teamITS dot com
Description:
------------
Even after installing /ports/devel/gnu-autoconf and /ports/devel/libtool per the docs and setting PHP_AUTOCONF about 20 different ways I still got the error about autoconf (PHP_AUTOCONF) not being found when running phpize.  Finally got it to work by linking:

autoconf -> autoconf259
autoheader -> autoheader259

So something (probably in phpize) is apparently looking for the non-versioned name.  Just a suggestion to put in the installation instructions that could save potential users lots of annoyance.

PS -- The "If you aren't sure that what you're about to report is a bug, you should ask for help using one of the means for support [listed here]." link is broken on this bug submission page.

PPS -- This form doesn't allow for PHP v4.3.11, 4.4.0, or 4.4.1 as choices.

- Steve Yates
- What do you get when you cross a Sysop with*^*(#%$&*@#%NO CARRIER

~ Taglines by Taglinator - www.srtware.com ~


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-24 02:06 UTC] rasmus@php.net
I am bogusing this since it has very little to do with APC.  If you feel strongly about not wanting to create a symlink to the correct auto* versions, file a but about that over on bugs.php.net.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 11:01:25 2019 UTC