php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56532 Add frequently used links to package info pages
Submitted: 2005-09-08 09:38 UTC Modified: 2005-09-14 10:10 UTC
From: techtonik@php.net Assigned: pajoye (profile)
Status: Not a bug Package: PECL website (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2005-09-08 09:38 UTC] techtonik@php.net
Description:
------------
Put links to package documentation and package CVS repository to package bugs/features interface. Probably in header of the site along with the name of the package to adopt concept of "package page" and not "package info in the main pear site".

Another approach would be to make dynamic menu on the left associated with the package itself, i.e. delimit PEAR options and package options. 

- Main:

-    * Home
-    * News
-    * Quality Assurance
-    * The PEAR Group

+ PEAR Home
+ Package Home

Documentation:

-    *  About PEAR
-    * Manual
-    * FAQ
-    * Support

+    * Package Manual
+    * Autogenerated API
?    * Wiki
?    * Web-site
?    * Support

- Downloads:

-    * List Packages
-    * Search Packages
-    * Statistics

+    * Download
+    * Package Stats

+    * Report Bug
+    * Request Feature

+    * Browse CVS


- Package Proposals:
-
-    * Browse Proposals
-    * New Proposal


Site options:
*    * List packages
*    * Search packages
*    * Statistics




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-08 19:29 UTC] pierre dot php at gmail dot com
They are all present either in the header or in the package pages (where they could be used).
 [2005-09-14 10:10 UTC] techtonik@php.net
Sorry if I wasn't clear enough. I'd like to see direct links from bug interface to package documentation and package CVS, because it is obvious. I can't see them in header. Clicking package page is often too repetitive task. Thank god this info is not hidden within .tgz. =)

Additional feature - track users browsing (anonymously) to give some grounds into future pearweb refactoring =) and/or improve navigation. de ja vue
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Aug 20 22:01:30 2019 UTC