php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56194 pprofp hangs, endless loop
Submitted: 2004-09-20 17:04 UTC Modified: 2004-09-24 09:12 UTC
From: tomsommer@php.net Assigned:
Status: Closed Package: apd (PECL)
PHP Version: 5.0.0b1 (beta1) OS: Linux Redhat 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tomsommer@php.net
New email:
PHP Version: OS:

 

 [2004-09-20 17:04 UTC] tomsommer@php.net
Description:
------------
When running the command "pprofp" (with or without arguments) the program starts consuming 100% CPU and just continues to hang without any sign of stopping or of output

Using PHP5.0.1, APD 1.0

If you need further information, than the details below, please don't hesitate to ask.

Reproduce code:
---------------
# pprofp

Actual result:
--------------
The following is the result of a few seconds of running "strace pprofp": http://dev.tsn.dk/pprofp.strace.txt

Looks like an endless loop, Wez called it an "Exec Bomb".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-24 09:12 UTC] tomsommer@php.net
Fixed in APD CVS
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Nov 15 04:01:25 2018 UTC