php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55886 disposition-filename doesn't contain file extension
Submitted: 2003-10-05 08:08 UTC Modified: 2008-01-24 19:14 UTC
From: dk at ntec dot nl Assigned: shire (profile)
Status: Closed Package: mailparse (PECL)
PHP Version: 4.3.3 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
45 + 28 = ?
Subscribe to this entry?

 
 [2003-10-05 08:08 UTC] dk at ntec dot nl
Description:
------------
When an email contains an attachement with a 
content-disposition header, then the 'disposition-filename' 
variable doesn't contain the filename's extension. 
 
Example headers for an attachment: 
Content-Type: application/download 
Content-Transfer-Encoding: base64 
Content-Disposition: attachment; filename=patch.exe 
 
The disposition-filename is set to patch instead of patch.exe 
 
 
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-28 07:16 UTC] wez@php.net
is this still the case with the latest mailparse package?
 [2005-10-23 09:17 UTC] mike@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2007-06-21 12:57 UTC] ablyler at bitleap dot com
Yes, this issue does still exist in the latest mailparse package.
 [2007-06-21 15:24 UTC] ablyler at bitleap dot com
I believe the patch below should fix the issue:

--- mailparse-2.1.1/php_mailparse_rfc822.c  2005-02-28 01:21:45.000000000 -0500
+++ mailparse-2.1.1/php_mailparse_rfc822.c  2007-06-21 15:07:18.000000000 -0400
@@ -76,7 +76,7 @@
        192, 192, 192, 192, 192, 192, 192, 192, 
        192, 192, 192, 192, 192, 192, 192, 192, 
         96,  64,   0, 192, 192,  64, 192, 192, 
-        64,  64, 192, 192,  64, 192,  64,  64, 
+        64,  64, 192, 192,  64, 192, 192,  64, 
        192, 192, 192, 192, 192, 192, 192, 192, 
        192, 192,  64,  64,  64,  64,  64,  64, 
         64, 192, 192, 192, 192, 192, 192, 192,
 [2007-06-27 15:24 UTC] wez@php.net
Reopened by user request
 [2007-12-06 14:54 UTC] shire@php.net
Just tested this and I'm unable to reproduce this with the headers listed.  And I can't update with the provided patch unless we have the changes to the .re file that generates it.  Can you verify that this is still a problem in CVS Head, and/or provide an updated patch for the .re file with a reproduce script?
 [2008-01-24 19:14 UTC] shire@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

I can reproduce on 2.1.1, but appears to be fixed in latest release.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jun 15 20:01:27 2019 UTC