|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5584 ibase_fetch_object() returns empty fields with IB 6
Submitted: 2000-07-14 09:12 UTC Modified: 2000-07-14 10:18 UTC
From: edemorsy at online dot fr Assigned:
Status: Closed Package: Other
PHP Version: 4.0.1pl2 OS: Linux Redhat 6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: edemorsy at online dot fr
New email:
PHP Version: OS:


 [2000-07-14 09:12 UTC] edemorsy at online dot fr
When I run a script like this one...

$categres = ibase_query("SELECT id, pere, titre, fullname FROM se_categ ORDER BY fullname ASC");
while ($data = ibase_fetch_object($categres)) $ListCateg[]=stripslashes($data->fullname);

... $data->fullname is empty, but if I use ibase_fetch_row(), the whole thing works well.... not blocking, but really annoying !

I saw that I had to use dialect 1 for my database, but even after switching my db to dialect 1 using gfix, it still doesn't work....


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-14 10:18 UTC] edemorsy at online dot fr
Ooops.... actually it works fine : the only "problem" is that IB stores fieldnames in upper case, for example here I just have to ask for $data->FULLNAME

Thanks get_object_vars :o)))
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 11:05:53 2022 UTC