php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5580 httpd core dumps when compiled with sybase & oracle
Submitted: 2000-07-14 06:01 UTC Modified: 2000-08-27 18:25 UTC
From: pip at compsoc dot man dot ac dot uk Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.0.1pl2 OS: Linux (RedHat 6.2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pip at compsoc dot man dot ac dot uk
New email:
PHP Version: OS:

 

 [2000-07-14 06:01 UTC] pip at compsoc dot man dot ac dot uk
PHP4pl2 compiled fine with apache with the following arguments:

./configure --with-apache=/usr/local/apache_1.3.12 --enable-track-vars --with-oracle=/db/ora1/app/oracle/product/8.1.6 --with-sybase-ct=/opt/sybase-11.9.2

.. but when you try and start apache, it core dumps.

I'd previously compiled PHP4 with Oracle support, which worked fine!

Any other information available upon request.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-14 07:42 UTC] pip at compsoc dot man dot ac dot uk
GDB backtrace:

(gdb) backtrace
#0  0x4081ed81 in main_arena () from /lib/libc.so.6
#1  0x4077a7a2 in buffered_vfprintf (s=0x4081ece0, 
    format=0xbfffde18 "\n\nThe context allocation routine failed when it tried to load localization files!!\n", args=0xbfffd7c4) at vfprintf.c:1767
#2  0x40775986 in _IO_vfprintf (s=0x4081ece0, 
    format=0xbfffde18 "\n\nThe context allocation routine failed when it tried to load localization files!!\n", ap=0xbfffd7c4) at vfprintf.c:1029
#3  0x4077e047 in fprintf (stream=0x4081ece0, 
    format=0xbfffde18 "\n\nThe context allocation routine failed when it tried to load localization files!!\n") at fprintf.c:32
#4  0x4007effe in com_perr () from /opt/sybase-11.9.2/lib/libcomn.so
#5  0x40070e1d in com_intl_verify_ctxloc ()
   from /opt/sybase-11.9.2/lib/libcomn.so
#6  0x401124ad in cs_ctx_alloc () from /opt/sybase-11.9.2/lib/libcs.so
#7  0x80d170b in php_minit_sybase ()
#8  0x80e5164 in zend_startup_module ()
#9  0x807da4c in php_startup_extensions ()
#10 0x807e433 in php_startup_internal_extensions ()
#11 0x807dc65 in php_module_startup ()
#12 0x807bf33 in sapi_apache_send_headers ()
#13 0x807c6a6 in php_init_handler ()
#14 0x8114669 in ap_init_modules ()
#15 0x811e5ed in main ()
#16 0x407489cb in __libc_start_main (main=0x811e2bc <main>, argc=1, 
    argv=0xbffff8b4, init=0x8063108 <_init>, fini=0x814bb9c <_fini>, 
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffff8ac)
    at ../sysdeps/generic/libc-start.c:92
(gdb) 


 [2000-07-15 03:32 UTC] joey at cvs dot php dot net
Whatever starts the apache process needs to have
the SYBASE environment variable set.

I will see if I can't fix this in CVS tonight.
 [2000-07-15 04:59 UTC] pip at compsoc dot man dot ac dot uk
I tried this:

[root@penguin apache]# export SYBASE=/opt/sybase-11.9.2 
[root@penguin apache]# bin/httpd
Segmentation fault (core dumped)
[root@penguin apache]#

I'm going to re-compile everything with SYBASE set at compilation time - I'll let you know the result......
 [2000-07-15 06:31 UTC] pip at compsoc dot man dot ac dot uk
Recompiled with SYBASE set, same backtrace....

Tried adding SYBASE value to apachectl - still cores.

I've already added /opt/sybase-11.9.2/lib to ld.so.conf and ran ldconfig (did that a while ago).
 [2000-07-18 09:43 UTC] pip at compsoc dot man dot ac dot uk
Any more ideas? :-(
 [2000-07-19 00:29 UTC] joey at cvs dot php dot net
Where did you get these sybase libs?
 [2000-07-19 01:22 UTC] pip at compsoc dot man dot ac dot uk
Originally I tried compiling against the ones in the original Sybase RPMs, but after they failed I downloaded the RPM from your website.
 [2000-07-19 01:36 UTC] pip at compsoc dot man dot ac dot uk
Also see this bug report to the PHP-INST list....

Date: Tue, 18 Jul 2000 20:17:42 +0200
From: David Clark <clarkd@icon.co.za>
To: php-install@lists.php.net
Subject: [PHP-INST] Apache core dumps after compiling with sybase-ct
 [2000-08-27 18:03 UTC] sniper@php.net
I might be wrong, but isn't that --with-oracle for oracle versions below 8.x.x ??
So you should use --with-oci8 instead. 

--Jani

 [2000-08-27 18:25 UTC] sniper@php.net
User feedback: 
------------

No - here's what I did to solve it (e-mail from a kind soul :-):


"I had the same prolem; to fix it, do the following... 

Firstly, make sure that $SYBASE points to the sybase installation; you've
done that.

Secondly, "$SYBASE/locales/locales.dat" needs to be edited...

Go to the section beginning w/ "[linux]" and copy the line starting with
ENGLISH to a new line...

Then replace the word "ENGLISH" with "en_US".

~Voila... fixed.  You shouldn't have to recompile apache/php

RedHat Linux 6.2 sets $LANG=en_US in the default environment(which is the
standard) but Sybase expects "us_english", and CT-Lib
dies..."

---

So not a bug in PHP but in Sybase.

--Jani
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Feb 26 19:01:24 2021 UTC