php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #55458 variables_order should contain E by default
Submitted: 2011-08-19 09:40 UTC Modified: 2015-01-10 13:27 UTC
Votes:4
Avg. Score:4.0 ± 0.7
Reproduced:4 of 4 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (25.0%)
From: cweiske@php.net Assigned:
Status: Wont fix Package: *Configuration Issues
PHP Version: 5.3.7 OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-08-19 09:40 UTC] cweiske@php.net
Description:
------------
The default php.ini-production[1] sets variables_order to "GPCS", which misses the "E" for environment variables.

This change was introduced in revision 277363  on Tue Mar 17 19:19:17 2009 by johannes:
> MFH: Replace old php.ini files with the new ones according to
> http://wiki.php.net/rfc/newinis (by Eric Lee Stewart)

The wiki page writes:
> There is a performance penalty paid for the registration of
> these arrays and because ENV is not as commonly used as the
> others, ENV is is not recommended on productions servers.

Since superglobals are only registered when they are used by the code (JIT), there should not really be a performance penalty, and E should be included in the default production setting.


[1] http://svn.php.net/viewvc/php/php-src/trunk/php.ini-production


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-10 00:54 UTC] danack@php.net
-Status: Open +Status: Feedback
 [2015-01-10 00:54 UTC] danack@php.net
The change was apparently done because of an approved RFC. Changing to use E again would require considering the security considerations and a new RFC.

Can you open a discussion on the internals list if you think this is still an issue to be discussed?
 [2015-01-10 13:18 UTC] cweiske@php.net
-Status: Feedback +Status: Open
 [2015-01-10 13:18 UTC] cweiske@php.net
No, I won't fight for bug from four years ago anymore.
 [2015-01-10 13:27 UTC] leigh@php.net
-Status: Open +Status: Wont fix
 [2015-01-10 13:27 UTC] leigh@php.net
Lets close it off then :)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 18:01:25 2019 UTC