php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #55242 upload_tmp_dir should be PHP_INI_ALL since open_basedir became PHP_INI_ALL
Submitted: 2011-07-19 13:23 UTC Modified: 2011-09-16 04:13 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: spamik at yum dot pl Assigned:
Status: Not a bug Package: Safe Mode/open_basedir
PHP Version: 5.3.6 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: spamik at yum dot pl
New email:
PHP Version: OS:

 

 [2011-07-19 13:23 UTC] spamik at yum dot pl
Description:
------------
http://pl2.php.net/manual/pl/ini.list.php

since open_basedir is PHP_INI_ALL since 5.3.x it makes no sense that 
upload_tmp_dir is still PHP_INI_SYSTEM. Those functions are entwined, even 
documentation says so:

"upload_tmp_dir string
The temporary directory used for storing files when doing file upload. Must be 
writable by whatever user PHP is running as. If not specified PHP will use the 
system's default.

If the directory specified here is not writable, PHP falls back to the system 
default temporary directory. If open_basedir is on, then the system default 
directory must be allowed for an upload to succeed."


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-15 15:57 UTC] iliaa@php.net
-Status: Open +Status: Bogus
 [2011-09-15 15:57 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Input (including file uploads) processing is done before the script is executed, 
this means any ini_set() calls within the script won't matter. For that reason the 
setting remains as PHP_INI_SYSTEM.
 [2011-09-16 04:12 UTC] spamik at yum dot pl
>> Input (including file uploads) processing is done before the script is executed

I know that, if it were not like that I would chagne it myself. Still a valid 
bug/feature request.
 [2011-09-16 04:13 UTC] spamik at yum dot pl
-Type: Bug +Type: Feature/Change Request
 [2011-09-16 04:13 UTC] spamik at yum dot pl
-
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu May 23 20:01:28 2019 UTC