php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #55110 Missing method DOMNode::isEqualNode() in documentation
Submitted: 2011-07-02 02:27 UTC Modified: 2011-07-02 02:38 UTC
From: rodolphe dot gerber at lemon dot ch Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.3.6 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rodolphe dot gerber at lemon dot ch
New email:
PHP Version: OS:

 

 [2011-07-02 02:27 UTC] rodolphe dot gerber at lemon dot ch
Description:
------------
The method is currently available in my 5.3.5 installation, but cannot be found on php.net manual.
On other site, i can access it on old version like here http://php.undmedlibrary.org/manual/en/function.dom-domnode-isequalnode.php

Expected result:
----------------
My goal is to understand the difference between isSameNode and isEqualNode, and be sure php/libxml is fully usable.

Actual result:
--------------
Only DOMNode::isSameNode can be found, with poor information. May be better to say what it does instead of what it does not.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-02 02:38 UTC] frozenfire@php.net
-Status: Open +Status: Bogus
 [2011-07-02 02:38 UTC] frozenfire@php.net
DOMNode::isEqualNode is not implemented yet. It's available in the Reflection 
data, but because there is no code associated with the function, it's 
fundamentally useless.

As far as an understanding of the methods goes, here are two relevant links:
http://www.w3.org/TR/2003/WD-DOM-Level-3-Core-20030226/DOM3-Core.html#core-
Node3-isSameNode
http://www.w3.org/TR/2003/WD-DOM-Level-3-Core-20030226/DOM3-Core.html#core-
Node3-isEqualNode

Here is the source code relating to isEqualNode:
http://svn.php.net/viewvc/php/php-src/trunk/ext/dom/node.c?view=markup#l1713

Since there is nothing to be done for this, I'll mark it bogus. If this method 
is implemented in the future, I'll gladly document it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 27 18:01:29 2020 UTC