php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54303 windows.php.net not working
Submitted: 2011-03-18 10:23 UTC Modified: 2011-07-06 05:31 UTC
Votes:26
Avg. Score:4.8 ± 0.5
Reproduced:24 of 24 (100.0%)
Same Version:14 (58.3%)
Same OS:16 (66.7%)
From: shehi at imanov dot name Assigned: pajoye (profile)
Status: Not a bug Package: Systems problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
 [2011-03-18 10:23 UTC] shehi at imanov dot name
Description:
------------
Can't access windows.php.net? Is the site down?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-18 10:25 UTC] aharvey@php.net
-Status: Open +Status: Verified -Package: Website problem +Package: Systems problem
 [2011-03-18 10:25 UTC] aharvey@php.net
Looks down here as well.
 [2011-03-18 10:27 UTC] tyra3l at gmail dot com
some info:

thor:~# nslookup windows.php.net
Server:         109.74.194.20
Address:        109.74.194.20#53

Non-authoritative answer:
windows.php.net canonical name = ovh.php.net.
Name:   ovh.php.net
Address: 213.251.181.15

thor:~# nmap windows.php.net -p80 -P0

Starting Nmap 5.00 ( http://nmap.org ) at 2011-03-18 10:27 CET
Interesting ports on pecl2.php.net (213.251.181.15):
PORT   STATE  SERVICE
80/tcp closed http

Nmap done: 1 IP address (1 host up) scanned in 0.10 seconds

Tyrael
 [2011-03-18 11:22 UTC] tyra3l at gmail dot com
it came back.

thor:~# nmap windows.php.net -p80 -P0

Starting Nmap 5.00 ( http://nmap.org ) at 2011-03-18 11:21 CET
Interesting ports on pecl2.php.net (213.251.181.15):
PORT   STATE SERVICE
80/tcp open  http

Nmap done: 1 IP address (1 host up) scanned in 0.10 seconds

Tyrael
 [2011-03-18 19:08 UTC] mail dot will at gmail dot com
Someone said site was up.  It's still down for me.
 [2011-03-19 15:11 UTC] ajlcomp at myfairpoint dot net
I am getting the same problem from two different desktps.
 [2011-03-19 15:20 UTC] radiant dot summit at gmail dot com
I need to built php x86 on my own but it seems wiki.php.net & pecl2.php.net down :(, especially this path http://pecl2.php.net/downloads/php-windows-builds/php-libs/VC9/x86/ that i would like really need to access, in my side wiki & pecl2 both shown this message "Sorry for the inconvenience, we are working on it", is there any ETA when both of the subdomain will be up?
 [2011-03-19 17:32 UTC] robert dot h dot fletcher at ieee dot org
Get "Sorry for the inconvenience, we are working on it"
for following URLs
http://windows.php.net/download
http://wiki.php.net/internals/windows/stepbystepbuild
 [2011-03-19 18:12 UTC] radiant dot summit at gmail dot com
yes the windows subdomain seems to be down also, are they got hacked or server fault?
 [2011-03-20 13:50 UTC] lee dot leeburns at gmail dot com
Is there anywhere else to download the windows zip files from? Everywhere I've 
found seems to point back here
 [2011-03-21 02:01 UTC] jerrycraker at Yahoo dot com
Same problem here.  Still Down.  Try on Comcast ISP and Cell (Verizon) network.  Kinda wise there is a mirror somewhere...  Is it me or this site seem to be down quite often? Sure seems that way from the google search... You would think... download.com or something would have a up to date copy... PHP... IS pretty fundimental tech of the web...
 [2011-03-21 12:23 UTC] johndough at fastmail dot fm
Three days downtime is pretty bad. If anyone knows any alternative mirros or can host the files on their own that would be much appreciated.
 [2011-03-21 12:34 UTC] lee dot leeburns at gmail dot com
Filecluster have 5.3.3 (where I got my copy). It will do for me for now until this 
site comes back up.
http://www.filecluster.com/downloads/PHP.html
 [2011-03-21 15:58 UTC] info at galtscat dot com
Still inaccessible with the resultant page message.  Sorry for the inconvenience, we are working on it.  Similar messages are received from the mirrors at http://www.filecluster.com/downloads/PHP.html.  This is a very significant issue that nobody seems to be addressing.
 [2011-03-21 19:35 UTC] ntmott at gmail dot com
someone has mentioned a mirror here: 

http://secunia.com/community/forum/thread/show/7897
 [2011-03-22 03:13 UTC] JerryCraker at Yahoo dot com
All the "Mirror" posted so far are ALL linking back to PHP.net and getting the same message... I guess everyone thought about being modular, no one thought about redundancy? ha ha ha...  Well... I hope PHP best of luck in fixing this... but I'll be wait'n for it. =D  Cheers, guys!
 [2011-03-22 03:25 UTC] scumdogg at gmail dot com
Anyone have any idea when the Windows binaries will be available again? I need them for a new project and have been trying to get them for the past 2 days only to be greeted with the same error and no mirrors.
 [2011-03-22 05:40 UTC] npx2004 at gmail dot com
Softpedia Has Mirror ...
http://www.softpedia.com/progDownload/PHP-for-Windows-Download-6660.html
Click [Softpedia Mirror] not [Extenal Mirror]
[External Mirror] Point Back to [windows.php.net]
 [2011-03-22 11:35 UTC] yuioooo at gmail dot com
So no-one is looking  into this at all? Several days now, and no-one can download php, this is just getting ridiculous to be honest.
I need version 5.3.x for win32 vc9. (i.e. "php-5.3.6-nts-Win32-VC9-x86.msi").
I've been googling for hours now, and the only places I can find it is on Russian sites, and I'm not gonna grab it there.
Does someone have a valid download site for any of the installers, please?
 [2011-03-22 13:19 UTC] smithrn at gmail dot com
I'm having troubles too. Does anybody have a mirror for the PHP 5.3.6 Windows source?
 [2011-03-22 13:31 UTC] shoty_ro at yahoo dot com
I can't belive this is not being fixed. It says "Sorry for the inconvenience, we are working on it".
 [2011-03-22 14:02 UTC] presidente_del_consiglio at email dot it
From now:
We're sorry, but [windows|wiki].php.net is down for maintenance

As you may have heard, it was discovered on March 19 that one of the php.net servers was compromised by unknown attackers. As soon as the php.net system administration team were made aware of this, the affected server was disabled.

Unfortunately, the server in question was the normal host of this site, and as a result, [wiki|windows].php.net will be unavailable until the server has been rebuilt. We are working to have this done as quickly as possible, but cannot provide an estimated time of restoration at this time.

To reiterate what the security notice says, at no time was the integrity of the PHP source code compromised, and no other servers or mirrors were affected.

We thank you for your patience, and for using PHP.

— php.net team
 [2011-03-22 14:54 UTC] ntmott at gmail dot com
Good to see an updated message. One thing I don't quite understand is why the windows installers can't be temporarily placed on the main php site... would that be a huge job?
 [2011-03-22 14:56 UTC] ntmott at gmail dot com
...or even let apachelounge.com host them temporarily
 [2011-03-23 01:13 UTC] presidente_del_consiglio at email dot it
http://windows.php.net seems to working now... but http://pecl2.php.net not yet! :(
 [2011-03-24 16:01 UTC] tn at neidhart dot info
I need the file http://pecl2.php.net/downloads/php-windows-builds/php-libs/binary-tools.zip. Is there any mirror?
 [2011-03-25 22:17 UTC] D666l at tut dot by
I also need the file
http://pecl2.php.net/downloads/php-windows-builds/php-libs/binary-tools.zip.
Is there any mirror?
 [2011-03-26 13:29 UTC] presidente_del_consiglio at email dot it
I've found this: http://www.hotfilesearch.com/download/53230260-binary-tools.zip-Uploaded-by-www.sitename.com.html
Add to saved file the zip extension!
 [2011-03-28 12:04 UTC] bjori@php.net
-Status: Verified +Status: Assigned -Assigned To: +Assigned To: pajoye
 [2011-03-28 12:04 UTC] bjori@php.net
windows.php.net has been working for several days now.
As for pecl2.php.net.. Pierre?
I am unsure what exactly was hosted there..
 [2011-03-28 12:14 UTC] pajoye@php.net
-Status: Assigned +Status: Bogus
 [2011-03-28 12:14 UTC] pajoye@php.net
it is back since a week now.

As of pecl2, other issue.
 [2011-03-29 03:28 UTC] radiant dot summit at gmail dot com
why it tooks so long to bring back pecl2.php.net? what's so hard to display a directory listing on apace and afaik i don't see any probable security concern about it? if you needs help just mail me.
 [2011-03-30 11:22 UTC] tn at neidhart dot info
I need also access to http://wiki.php.net/internals/windows/stepbystepbuild

Does anyone know a mirror? 

How long does it take to bring all these sites back? From my perspective it is not very professional... (e.g. websites down for more than a week now, no updated status, no communicated backup/mirror)
 [2011-04-07 07:42 UTC] radiant dot summit at gmail dot com
Any news about pecl2.php.net? it's been nearly 20 days since it's down :(
 [2011-04-11 14:35 UTC] super-suselik at mail dot ru
Please UP pecl2.php.net......
 [2011-05-01 01:33 UTC] dlee at danlee dot ca
Is there any news to the ETA of http://pecl2.php.net/downloads/php-windows-builds/php-libs/ getting back up and running ?  Even if the wiki is not ready, at a least the ability to download the files would be great.
 [2011-07-06 04:38 UTC] unexplained at gmail dot com
this is nearly 3 months http://pecl2.php.net/downloads/php-windows-builds/php-libs/ down, when it will be back?
 [2014-08-14 13:50 UTC] julioszabo at hotmail dot com
Can't access windows.php.net? Is the site down again?
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 12:01:25 2019 UTC