php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #53994 utf8_decode for iso-8859-15
Submitted: 2011-02-11 10:50 UTC Modified: 2015-08-19 19:34 UTC
Votes:3
Avg. Score:3.7 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: markokarjalainen at kolumbus dot fi Assigned:
Status: Wont fix Package: *Languages/Translation
PHP Version: 5.3.5 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: markokarjalainen at kolumbus dot fi
New email:
PHP Version: OS:

 

 [2011-02-11 10:50 UTC] markokarjalainen at kolumbus dot fi
Description:
------------
Is it possible extend utf8_decode function with charset iso-8859-15(latin 9) version?
http://en.wikipedia.org/wiki/ISO/IEC_8859-15

Currently utf8_decode uses iso-8859-1
Main reason of need is we need €(EUR) char in conversions

It can be done second optional parameter.
string utf8_decode ( string $data [] [, string $out_charset])


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-08-18 13:18 UTC] cmb@php.net
-Status: Open +Status: Feedback
 [2015-08-18 13:18 UTC] cmb@php.net
It's rather unlikely that utf8_decode() will be enhanced, because
there are already mb_convert_encoding() and iconv().

Can this request be closed?
 [2015-08-19 18:45 UTC] markokarjalainen at kolumbus dot fi
-Status: Feedback +Status: Open
 [2015-08-19 18:45 UTC] markokarjalainen at kolumbus dot fi
While there is already function that handle diffirent charsets, this can be closed.

Maybe beter change this function is silently extend to iso-8859-15 charset, so that iso-8859-15 charset work in iso-8859-1 charsets. If i understooded, this was method in many software when iso-8859-15 charset released.
 [2015-08-19 19:34 UTC] requinix@php.net
-Status: Open +Status: Wont fix
 [2015-08-19 19:34 UTC] requinix@php.net
> Maybe beter change this function is silently extend to iso-8859-15 charset, so
> that iso-8859-15 charset work in iso-8859-1 charsets.
That's not possible. The two charsets differ at 8 code points so there's no way to combine them. And even if they could be, it would be crazy to have a string be in two encodings simultaneously.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 06:01:26 2020 UTC