php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53919 ld: Mismatched ABI for -lclntsh
Submitted: 2011-02-03 13:49 UTC Modified: 2011-02-04 23:31 UTC
From: davidmauri at gmail dot com Assigned: sixd (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.17 OS: HP-UX 11.31
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: davidmauri at gmail dot com
New email:
PHP Version: OS:

 

 [2011-02-03 13:49 UTC] davidmauri at gmail dot com
Description:
------------
Hi,
I need to compile PHP 5.2.17 with ORACLE InstantClient( 11.1.0.7 64bits).
My SO is a HP-UX Itanium (11.31).

In "configure" phase any problem appears, this is my configure command:
./configure --with-apxs2=$ORACLE_HOME/ohs/bin/apxs --prefix=$ORACLE_HOME --with-config-file-path=$CONFIG_FILE_PATH --with-oci8=instantclient,/opt/oracle/as/ohsext11/instantclient_11_1 --disable-rpath 

But the "make" phase fails:

(...)
end_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf                                                          .lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash                                                          .lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend                                                          _exceptions.lo Zend/zend_strtod.lo Zend/zend_objects.lo Zend/zend_object_handler                                                          s.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo                                                           sapi/apache2handler/mod_php5.lo sapi/apache2handler/sapi_apache2.lo sapi/apache2                                                          handler/apache_config.lo sapi/apache2handler/php_functions.lo main/internal_func                                                          tions.lo -liconv -lrt -lm -lnsl -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -l                                                          clntsh -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxm                                                          l2 -lz -liconv -lm  -o libphp5.la
ld: Mismatched ABI for -lclntsh, found /opt/oracle/as/ohsext11/instantclient_11_                                                          1/libclntsh.so
Fatal error.
collect2: ld returned 1 exit status
*** Error exit code 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-03 21:22 UTC] sixd@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: sixd
 [2011-02-03 21:22 UTC] sixd@php.net
Not enough information about the environment, compiler etc was provided in this report.
 [2011-02-04 10:11 UTC] davidmauri at gmail dot com
-Status: Feedback +Status: Assigned
 [2011-02-04 10:11 UTC] davidmauri at gmail dot com
Info gcc/gmake:

gcc -v
Using built-in specs.
Target: ia64-hp-hpux11.31
Configured with: ../gcc/configure
Thread model: posix
gcc version 4.2.3

gmake -v
Thread model: posix
gcc version 4.2.3
n1821:oracle/home/oracle# gmake -v
GNU Make 3.81

SO:
uname -a
HP-UX n1821 B.11.31 U ia64 2131309830 unlimited-user license
 [2011-02-04 23:31 UTC] sixd@php.net
-Status: Assigned +Status: Bogus
 [2011-02-04 23:31 UTC] sixd@php.net
Based on email, there is no indication that you have any PHP build working in any configuration.  I recommend following up in a support channel first, and then opening bugs for specific problems as they are identified.  The bug DB is not a support forum.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 04:05:46 2022 UTC