php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52490 Delay with php_curl enabled in last builds (5.3.3 / 5.2.14)
Submitted: 2010-07-29 20:14 UTC Modified: 2011-11-16 14:08 UTC
Votes:4
Avg. Score:4.2 ± 0.8
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:3 (75.0%)
From: tanguy dot pruvot at gmail dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 5.3.3 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tanguy dot pruvot at gmail dot com
New email:
PHP Version: OS:

 

 [2010-07-29 20:14 UTC] tanguy dot pruvot at gmail dot com
Description:
------------
A simple "php -v" takes 2 seconds to display php version when php_curl is enabled 
in php.ini in last release (only)

I tried with only this extension enabled in both PHP 5.3.3 and 5.2.14

And the problem is not in extension sources.

PS: I make a WAMP package and i compile some of the extensions myself (mysql, 
xdebug, eaccelerator)

Seems same as : http://bugs.php.net/bug.php?id=50410

but... i make a new ticket because 5.2.13 version is fine here

Test script:
---------------
php -v

Expected result:
----------------
no delay


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-29 20:20 UTC] tanguy dot pruvot at gmail dot com
hmm just to specify i experienced that on Windows 7 x86... With VC6 Thread Safe 
builds on Windows 7 32bit
 [2011-11-16 14:08 UTC] felipe@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2011-11-16 14:08 UTC] felipe@php.net
-Status: Open +Status: Bogus
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed May 27 13:01:25 2020 UTC