php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52329 ftp_connect doesn't work on web script but works on command line
Submitted: 2010-07-13 15:28 UTC Modified: 2011-11-15 15:58 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: daniel dot requena at gmail dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 5.3.3RC2 OS: Centos
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: daniel dot requena at gmail dot com
New email:
PHP Version: OS:

 

 [2010-07-13 15:28 UTC] daniel dot requena at gmail dot com
Description:
------------
Hi,
I have the next script:
<?php
$ftp_host = '192.168.1.120';//'ftp.adrive.com';
if(!$connId = ftp_connect($ftp_host))
{
	echo "Not connected to {$ftp_host}!!";
}
else
{	
	echo "Connected!!";
	ftp_close($connId);
}
?>
When I call this script using command line with the next command:
>php pruftp.php, I always get "Connected!!", but when I call from accessible public url as the next: http://emucent/pruftp.php I always get Now connected to 1192.168.1.120. 
What can be the problem?

Expected result:
----------------
Connected!!

Actual result:
--------------
Not connected to 192.168.1.120!!

Patches

pruftp.txt (last revision 2010-07-13 13:32 UTC by daniel dot requena at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-11-15 15:58 UTC] felipe@php.net
-Status: Open +Status: Bogus
 [2011-11-15 15:58 UTC] felipe@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Probably due the firewall?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 28 00:03:34 2022 UTC