php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52100 PHP FREEZE
Submitted: 2010-06-16 17:45 UTC Modified: 2015-08-18 16:21 UTC
From: bbarnetm at yahoo dot com Assigned: cmb (profile)
Status: Not a bug Package: Apache2 related
PHP Version: 5.2.13 OS: W2K3 X64 SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
16 + 30 = ?
Subscribe to this entry?

 
 [2010-06-16 17:45 UTC] bbarnetm at yahoo dot com
Description:
------------
The web server is receiving attack using "w00tw00t.at.ISC.SANS.test0".

All the conection between PHP and MS SQL SERVER are freeze.

I must to restart the apache to continue using my web site.

Only PHP and MS SQL SERVER conection be affected

Test script:
---------------
w00tw00t.at.ISC.SANS.test0

Expected result:
----------------
Don't be freeze.

Actual result:
--------------
Freeze

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-16 19:20 UTC] johannes@php.net
-Status: Open +Status: Feedback
 [2010-06-16 19:20 UTC] johannes@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2010-06-16 19:31 UTC] bbarnetm at yahoo dot com
I wrote all the Information that I have, because in any log there are error message. But after the apache receive that string the PHP conection with my MS SQL SERVER be freeze.

I'm using:

ntwdblib.dll version: 2000.80.2039.0
php_mssql.dll version: 5.2.13.13

Thank you for any help that you can give me.
 [2010-06-16 19:33 UTC] bbarnetm at yahoo dot com
MS SQL 2005 SP3
 [2010-06-17 04:17 UTC] bbarnetm at yahoo dot com
-Status: Feedback +Status: Open
 [2010-06-17 04:18 UTC] bbarnetm at yahoo dot com
I wrote more information about this issue.

Thank you for your help.
 [2010-06-17 21:50 UTC] bbarnetm at yahoo dot com
Today appear the next error in my apache log after an attack began:

PHP Warning:  session_destroy() [<a href='function.session-destroy'>function.session-destroy</a>]: Session object destruction failed 

Any Idea ???
 [2010-06-18 02:35 UTC] felipe@php.net
Maybe related to bug #32330?
 [2015-08-18 16:21 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-08-18 16:21 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 20:05:45 2022 UTC