php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51874 phpize on PHP-GTK source throws "possibly undefined macro" error.
Submitted: 2010-05-20 21:54 UTC Modified: 2010-05-25 17:49 UTC
From: markskilbeck@php.net Assigned:
Status: Not a bug Package: PHP-GTK related
PHP Version: 5.3.2 OS: Linux (Ubuntu)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
35 + 32 = ?
Subscribe to this entry?

 
 [2010-05-20 21:54 UTC] markskilbeck@php.net
Description:
------------
Running phpize on the PHP-GTK source throws some possibly-undefined-macro errors.

I see that there are similar bugs already filed. However, the replies don't 
explain what is causing the error, instead they say 'fixed in cvs' - not helpful 
:P

Expected result:
----------------
phpize runs smoothly - no errors.

Actual result:
--------------
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100409
Zend Extension Api No:   220100409
configure.in:51: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure:4628: error: possibly undefined macro: AM_PATH_GLIB_2_0
configure:4759: error: possibly undefined macro: AM_PATH_GTK_2_0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-05-25 17:49 UTC] markskilbeck@php.net
-Status: Open +Status: Bogus
 [2010-05-25 17:49 UTC] markskilbeck@php.net
Turns out, you don't need phpize for PHP-GTK. Silly me :D
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 25 13:01:25 2020 UTC