php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50893 Reopen Bug #48763
Submitted: 2010-01-31 20:31 UTC Modified: 2010-02-01 20:39 UTC
From: headofsteam at gmx dot com Assigned:
Status: Not a bug Package: Zip Related
PHP Version: 5.2.12 OS: WinOs
Private report: No CVE-ID: None
 [2010-01-31 20:31 UTC] headofsteam at gmx dot com
Description:
------------
I believe bug #48763 has not been resolved and should be reopened.

I have just upgraded to v5.2.12 WinOS version to try to get around this error, noting in the report that it had been fixed in 5.2.11+

Taking a known original and good ods file, ZipArchive extracts correctly to a temp directory. Proof unzip works.

Using ZipArchive to repack the same directory to a new ods file still produces a corrupt ods as reported in the bug.

However, taking the same directory but using WinZip (r) to repack to a new file does work correctly. So the data itself has not been corrupted by the unpack. Something remains incorrect in in the ZipArchive packed file.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-31 20:39 UTC] pajoye@php.net
Please provide the archive you are using to test.
 [2010-02-01 16:18 UTC] headofsteam at gmx dot com
pajoye@php.net I emailed you a typical ods file - but TBH any will do I do not know how to attach it to this thread.
 [2010-02-01 19:50 UTC] jani@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Add comment to the bug you want reopened, DO NOT SPAM the tracker!!
 [2010-02-01 20:29 UTC] headofsteam at gmx dot com
jani@php.net - I am not spamming !!

I tried to add comment to the original bug report but was unable to do so because it is INCORRECTLY closed - or may have been resolved for linux OS last November - It certainly has not for WinOS PHP version 5.2.12. When I try to add comment to the closed bug report it is blocked.

I have now tried several ods files and all of them expand into a directory just fine.

None of them pack back into a OpenOffice readable file.

Searching the web it appears that this remains an unresolved issue.
 [2010-02-01 20:39 UTC] pajoye@php.net
keep cool everyone, I reopened the other one, let discuss your issue there.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Aug 22 07:01:26 2019 UTC