php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48789 foreach($a as $k => &$v) gives unexpected behavior
Submitted: 2009-07-03 15:46 UTC Modified: 2009-07-03 15:49 UTC
From: ehsmeng at gmail dot com Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 5.2.10 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ehsmeng at gmail dot com
New email:
PHP Version: OS:

 

 [2009-07-03 15:46 UTC] ehsmeng at gmail dot com
Description:
------------
The last foreach seems to corrupt $rows_unsorted. The last var_dump() in the log reports false.

Reproduce code:
---------------
    $rows_unsorted = array();
    for ($i = 0; $i < 4; $i++)
    {
        array_push($rows_unsorted, array("apa" . $i));
    }

    $rows_index = array();
    foreach ($rows_unsorted as $k => &$row)
    {
        array_push($rows_index, sprintf("%03d_%d", strlen($row[0]), $k));
    }

    for ($i = 0; $i < 4; $i++)
    {
        var_dump($rows_unsorted[$i]);
    }

    foreach ($rows_index as $idx)
    {
        list ($len, $rowOffs) = split('_', $idx);
        $row = false;
        $row = $rows_unsorted[0 + $rowOffs];

        var_dump($row);
    }

Expected result:
----------------
I was expecting all values in $rows_unsorted to have been dumped.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-03 15:48 UTC] ehsmeng at gmail dot com
Sorry, forgot: If I change &$row to $row in the first foreach all works as I expect it to.
 [2009-07-03 15:49 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jun 02 09:01:27 2020 UTC