php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48312 Posting Notes SPAM filtering
Submitted: 2009-05-17 17:28 UTC Modified: 2009-05-22 07:49 UTC
From: scott at thebrain dot ca Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2009-05-17 17:28 UTC] scott at thebrain dot ca
Description:
------------
Also see bug #45055 posted and dismissed as bogus.

Attempting to post an example of creating xml namespaces fails, identified as spam.

That earlier post complains no specific reason is given.
That earlier post suggests it may be caused by too many links.

Perhaps this is why there are no examples posted.

The note I tried to post follows:

Reproduce code:
---------------
---
From manual page: domdocument.createelementns
---

A namespace prefix example.

$doc = new DOMDocument('1.0', 'utf-8');
$root = $doc->createElementNS('http://www.w3.org/2005/Atom','element');
$doc->appendChild($root);
$root->setAttributeNS(
 'http://www.w3.org/2000/xmlns/'
 ,'xmlns:g'
 ,'http://base.google.com/ns/1.0');
$item = $doc->createElementNS(
 'http://base.google.com/ns/1.0'
 ,'g:item_type'
 ,'house);
$root->appendChild($item);
echo $doc->saveXML();
echo "\n",$item->namespaceURI;
echo "\n",$item->prefix;
echo "\n",$item->localName;

produces:

(I cannot paste the output or the automated spam detection thinks this note is spam - too many links?).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-22 07:49 UTC] bjori@php.net
We simply cannot remove that restriction due to spammers.
As your example was however good I have incorporated it into the docs (http://news.php.net/php.doc.cvs/4052).
It should show up in the docs later today.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 15:01:25 2019 UTC