php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47595 'Include' outputs only included file.
Submitted: 2009-03-08 08:12 UTC Modified: 2009-03-08 08:58 UTC
From: stas87 at i dot ua Assigned:
Status: Closed Package: Output Control
PHP Version: 5.2.9 OS: Vista
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: stas87 at i dot ua
New email:
PHP Version: OS:

 

 [2009-03-08 08:12 UTC] stas87 at i dot ua
Description:
------------
When i try to include file it outputs only that file without the page on which it was included

Reproduce code:
---------------
contents of file index.php
<?php
include"./file.php";
?>

Expected result:
----------------
contents of file index.php
included contents of file ./file.php

Actual result:
--------------
included contents of file ./file.php



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-08 08:58 UTC] stas87 at i dot ua
Sorry! The problem is solved! Forgot about mod_rewrite...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 10:01:24 2020 UTC