php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #47541 check all of command line for bad args
Submitted: 2009-03-02 05:22 UTC Modified: 2018-05-05 19:56 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: jidanni at jidanni dot org Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 5.2.9 OS: linux
Private report: No CVE-ID: None
 [2009-03-02 05:22 UTC] jidanni at jidanni dot org
Description:
------------
Many command line arguments should print an error if there is unexpected junk abord:

$ php -l LocalSettings.php ZZZZZ
No syntax errors detected in LocalSettings.php
$ php -l ZZZZZ LocalSettings.php 
Could not open input file: ZZZZZ

We see only the first argument is ever parsed.

There should be an error for the first line too.

-l is affected, and probably many other options are too.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-23 13:33 UTC] narf at devilix dot net
This is a duplicate of https://bugs.php.net/bug.php?id=40077
 [2018-05-05 19:56 UTC] requinix@php.net
-Status: Open +Status: Duplicate -Package: Feature/Change Request +Package: *General Issues
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 21:01:26 2019 UTC