php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #471 httpd exits on signal 11
Submitted: 1998-06-21 03:38 UTC Modified: 1998-06-25 17:46 UTC
From: banb at j-link dot or dot jp Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 3.0 Final Release OS: FreeBSD-2.2.6
Private report: No CVE-ID: None
 [1998-06-21 03:38 UTC] banb at j-link dot or dot jp
In refer to Bug#460,
Apache-1.3.0 with PHP3.0 DSO module on FreeBSD-2.2-stable
exits with signal 11.

This is because the libc(.so: dynamic link module)
in FreeBSD has the function named 'hash_destroy' that is
not identical to hash.o module in php3 source.
So, when mod_php3 calls 'hash_destroy',
the function of LIBC version is (loaded and) executed,
then crash.

I've resolved that problem in a simple way.
I changed the name 'hash_destroy' to 'hash_cleanup'
on all of the PHP3 source, and made the executable.

There might be better choises, but I hope the CVS will
make the changes. :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-06-25 17:46 UTC] rasmus
This has been fixed in CVS by Zeev
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Aug 22 05:01:27 2019 UTC