php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46867 "use...as" not suppored by Reflection::export()
Submitted: 2008-12-15 08:27 UTC Modified: 2009-01-05 07:18 UTC
From: naturallydigital at yahoo dot com Assigned:
Status: Not a bug Package: Reflection related
PHP Version: 5.3CVS-2008-12-15 (CVS) OS: *
Private report: No CVE-ID: None
 [2008-12-15 08:27 UTC] naturallydigital at yahoo dot com
Description:
------------
The Reflection API does not support the "use... as... " syntax for namespaces in 5.3 CVS. I ran the raw unzipped Win32 VC6 snapshot from snaps.php.net: "php -c php.ini-dist d:\reflect.php" (code below)



Reproduce code:
---------------
<?php
require_once("A\\B\\C.php");
use \A\B\C as D;
try
{
        Reflection::export(new ReflectionClass('D'));
}
catch (Exception $e)
{
        echo $e->getMessage();
}
?>


Expected result:
----------------
User class C (a.k.a. D) reflected in the Command Prompt window.


Actual result:
--------------
"Class D does not exist" output in the Command Prompt window.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-01 02:15 UTC] kalle@php.net
Should be same with class_alias(), I'm not sure if its intended for Reflection to support aliased classes
 [2009-01-02 02:12 UTC] johannes@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

In strins you always have to use the fully qualified name - we don't know where the string is coming from and the aliasing is done at compile time,not runtime ...
 [2009-01-05 07:18 UTC] naturallydigital at yahoo dot com
class_alias() didn't appear in the official documentation (http://wiki.php.net/doc/todo/undocumented). Thanks for pointing that out.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 06:01:27 2019 UTC