php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46372 Wrong redirection to PDO_MySQL docs instead of PDO_DBLIB (for MSSQL)
Submitted: 2008-10-23 18:18 UTC Modified: 2008-10-23 20:13 UTC
From: wiesemann@php.net Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wiesemann@php.net
New email:
PHP Version: OS:

 

 [2008-10-23 18:18 UTC] wiesemann@php.net
Description:
------------
http://www.php.net/pdo-mssql redirects to the PDO_MySQL documentation, i.e. to http://de.php.net/manual/en/ref.pdo-mysql.php

It's a not a mirror problem. Behaviour is also true for "de2", "de3", "us" and maybe other mirrors.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-23 18:22 UTC] wiesemann@php.net
(summary corrected)
 [2008-10-23 19:20 UTC] bjori@php.net
The extension is called pdo-dblib, not mssql.
Since there is no such ext as pdo-mssql we do our best to automatically figure out typos - which in this case "mysql" is the obvious choice.

 [2008-10-23 19:25 UTC] wiesemann@php.net
Wouldn't a page with search results be better? It's more likely to find a more reasonable page in less time, e.g. the pdo_dblib page.

BTW: I can't remember the exact search phrase, but it was a Google result that pointed me to "/pdo-mssql". Actually not something that should be in the index ...
 [2008-10-23 20:13 UTC] bjori@php.net
You can change your search preferences on http://php.net/my
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 21:05:44 2022 UTC