php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45811 file_exists crashes Apache when phar is enabled
Submitted: 2008-08-13 19:57 UTC Modified: 2008-08-18 20:20 UTC
From: guilhermeblanco at gmail dot com Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.3CVS-2008-08-13 (snap) OS: Windows Vista Home Premium 32bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: guilhermeblanco at gmail dot com
New email:
PHP Version: OS:

 

 [2008-08-13 19:57 UTC] guilhermeblanco at gmail dot com
Description:
------------
With phar enabled the code below crashes my Apache. I was requested to get a backtrace (#php.pecl @ efnet), here is the content:


Analysis Summary
  	
Type 	Description 	Recommendation
  Error	WARNING - DebugDiag was not able to locate debug symbols for C:\Server\php5.3.0-200808121402\ext\php_phar.dll, so the information below may be incomplete.

In httpd__PID__2124__Date__08_13_2008__Time_04_42_34PM__689__Second_Chance_Exception_C0000005.dmp the module C:\Server\php5.3.0-200808121402\ext\php_phar.dll has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000000 on thread 2
	Please follow up with the vendor of this module, The PHP Group, for further assistance with this issue.
  Information	DebugDiag determined that this dump file (httpd__PID__2124__Date__08_13_2008__Time_04_42_34PM__689__Second_Chance_Exception_C0000005.dmp) is a crash dump and did not perform any hang analysis. If you wish to enable combined crash and hang analysis for crash dumps, edit the CrashHangAnalysis.asp script (located in the DebugDiag\Scripts folder) and set the g_DoCombinedAnalysis constant to True.	 

	Analysis Details
  	

	Your browser settings are currently prohibiting this report's scripts from running.
This is preventing some features of this analysis report from displaying properly. To enable scripts to run, right-click the security warning above and choose "Allow Blocked Content..." or enable the "Allow active content to run in files on My Computer*" setting on the Advanced tab of your "Internet Options" dialog to avoid being prompted in the future


Table Of Contents
httpd__PID__2124__Date__08_13_2008__Time_04_42_34PM__689__Second_Chance_Exception_C0000005.dmp
   Faulting Thread

Report for httpd__PID__2124__Date__08_13_2008__Time_04_42_34PM__689__Second_Chance_Exception_C0000005.dmp

Report for httpd__PID__2124__Date__08_13_2008__Time_04_42_34PM__689__Second_Chance_Exception_C0000005.dmp
Type of Analysis Performed	  Crash Analysis
Machine Name	  BLANCO-LAPTOP
Operating System	  Windows Vista Service Pack 1
Number Of Processors	  2
Process ID	  2124
Process Image	  C:\Server\Apache2.2.8\bin\httpd.exe
System Up-Time	  14:44:18
Process Up-Time	  00:00:24

Thread 2 - System ID 4924
Entry point	  msvcrt!beginthreadex+86
Create time	  13/08/2008 16:42:10
Time spent in user mode	  0 Days 0:0:0.0
Time spent in kernel mode	  0 Days 0:0:0.0


Function 	    Arg 1 	    Arg 2 	    Arg 3 	  Source
0x00000000 	    00000001 	    040ed2f0 	    00000000 	  
php_phar+5d5b 	    00000001 	    040ed2f0 	    00000000 	  
php5ts!execute+cc5 	    00000000 	    00000000 	    00000000 	  


WARNING - DebugDiag was not able to locate debug symbols for C:\Server\php5.3.0-200808121402\ext\php_phar.dll, so the information below may be incomplete.

In httpd__PID__2124__Date__08_13_2008__Time_04_42_34PM__689__Second_Chance_Exception_C0000005.dmp the module C:\Server\php5.3.0-200808121402\ext\php_phar.dll has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000000 on thread 2
Module Information
Image Name: 	C:\Server\php5.3.0-200808121402\ext\php_phar.dll 	  Symbol Type: 	Export
Base address: 	0x00b00000 	  Time Stamp: 	Tue Aug 12 15:01:58 2008
Checksum: 	0x00000000 	  Comments: 	Thanks to Gregory Beaver, Marcus Boerger
COM DLL: 	False 	  Company Name: 	The PHP Group
ISAPIExtension: 	False 	  File Description: 	PHP Archive
ISAPIFilter: 	False 	  File Version: 	5.3.0alpha2-dev
Managed DLL: 	False 	  Internal Name: 	PHAR extension
VB DLL: 	False 	  Legal Copyright: 	Copyright ? 1997-2008 The PHP Group
Loaded Image Name: 	php_phar.dll 	  Legal Trademarks: 	PHP
Mapped Image Name: 	C:\Server\php5.3.0-200808121402\ext\php_phar.dll 	  Original filename: 	php_phar.dll
Module name: 	php_phar 	  Private Build: 	
Single Threaded: 	False 	  Product Name: 	PHP
Module Size: 	224,00 KBytes 	  Product Version: 	5.3.0alpha2-dev
Symbol File Name: 	php_phar.dll 	  Special Build: 	&



	Script Summary
  	
Script Name 	Status 	Error Code 	Error Source 	Error Description 	Source Line
CrashHangAnalysis.asp	Completed	 

Reproduce code:
---------------
<?php

if (file_exists('Foo.php')) {}

Actual result:
--------------
Apache crash

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-13 20:04 UTC] jani@php.net
Assigned to the PHAR maintainer.
 [2008-08-18 05:05 UTC] cellog@php.net
which apache version?  I'd like to try to reproduce on linux where I can gdb if necessary
 [2008-08-18 06:59 UTC] bjori@php.net
> Process Image	  C:\Server\Apache2.2.8\bin\httpd.exe

I assume that would be Apache2.2.8 he is running...
 [2008-08-18 15:00 UTC] cellog@php.net
I cannot reproduce this on windows or linux, please provide more information.
 [2008-08-18 20:20 UTC] cellog@php.net
no wonder I can't duplicate, this was already fixed in Bug #45613, making this bug a duplicate bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 10:01:24 2020 UTC