php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45014 Segmentation fault at end of program execution
Submitted: 2008-05-15 20:58 UTC Modified: 2008-05-20 09:06 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: lukasz at zhr dot pl Assigned:
Status: Closed Package: SPL related
PHP Version: 5.2.6 OS: FreeBSD 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lukasz at zhr dot pl
New email:
PHP Version: OS:

 

 [2008-05-15 20:58 UTC] lukasz at zhr dot pl
Description:
------------
Basically, doing anything results in correct script execution and a segmentation fault afterwards. Even running php manually and typeing ^D produces this error.

Disabling _any_ of the following modules causes php to function normally again:
-spl
-pdo
-pspell
-simplexml
but the backtrace suggests it is an spl error.

Reproduce code:
---------------
-Run php and type any code, even no code at all.
-Or run php -v


Actual result:
--------------
(gdb) run
Starting program: /usr/local/bin/php
^D
Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
(gdb) backtrace
#0  0x00000000 in ?? ()
#1  0x293e3694 in __do_global_dtors_aux () from /usr/local/lib/php/20060613-debug/spl.so
#2  0x293fb3d8 in _fini () from /usr/local/lib/php/20060613-debug/spl.so
#3  0x282c3040 in ?? ()
#4  0x282b9018 in ?? () from /libexec/ld-elf.so.1
#5  0xbfbfe628 in ?? ()
#6  0x28298a96 in elf_hash () from /libexec/ld-elf.so.1
#7  0x2829b71c in dlclose () from /libexec/ld-elf.so.1
#8  0x081984a2 in module_destructor (module=0x836d900) at /usr/ports/lang/php5/work/php-5.2.6/Zend/zend_API.c:1943
#9  0x0819dae8 in zend_hash_apply_deleter (ht=0x82ab5e0, p=0x8383540) at /usr/ports/lang/php5/work/php-5.2.6/Zend/zend_hash.c:805
#10 0x0819dc6c in zend_hash_graceful_reverse_destroy (ht=0x82ab5e0) at /usr/ports/lang/php5/work/php-5.2.6/Zend/zend_hash.c:840
#11 0x08190f1a in zend_shutdown () at /usr/ports/lang/php5/work/php-5.2.6/Zend/zend.c:814
#12 0x0813e8e2 in php_module_shutdown () at /usr/ports/lang/php5/work/php-5.2.6/main/main.c:1906
#13 0x08208a66 in main (argc=1, argv=0xbfbfe8d4) at /usr/ports/lang/php5/work/php-5.2.6/sapi/cli/php_cli.c:1341

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-15 21:52 UTC] felipe@php.net
What configure line did you use? 
 [2008-05-20 09:06 UTC] lukasz at zhr dot pl
I just found this bugreport is a duplicate of that one:
http://bugs.php.net/bug.php?id=42700

As in that case, reinstall fixed it as well.
Sorry for bothering you.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 08:03:18 2022 UTC