|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #450 Apache process runs out of control
Submitted: 1998-06-10 18:19 UTC Modified: 1998-08-23 15:32 UTC
From: jase at sensis dot com Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 3.0 Final Release OS: Solaris 2.5.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: jase at sensis dot com
New email:
PHP Version: OS:


 [1998-06-10 18:19 UTC] jase at sensis dot com
After running some php scripts in succession 
(accessing an oracle server), a cgi
script will cause the apache httpd process to chew up
all the available cpu, and bring the server to a halt.

This also happens is a php script is run which contains
an "exec" function, instead of a cgi script.

Using Apache 1.3.0.  Configured as follows:

Configured php as follows:

I submitted this bug before as an Oracle bug, but I was told
that it was not an Oracle bug.  The solution was to try the
latest CVS, which I did, but as of the 3.0 Final Release, 
the bug is still not fixed.

I've found a way to prevent this from killing my whole
system by putting a limit on the cpu time before starting
the apache server.  The command I give is
ulimit -t 10
Once the daemon uses 10 seconds of cpu time, it gets
killed.  The main httpd daemon just starts up another one.
Then, I have a cron job which kills and restarts the whole
apache server at night.  The only problem is, when one of
the process starts to go out of control, the user who tried
to execute the cgi script gets an error.

If you need any more info, let me know.  Thanks!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [1998-08-23 15:32 UTC] zeev
Does the same thing happen with the static version of PHP?

final:  This seems to be related to the dynamic loading of
modules, which isn't yet very reliable as of Apache 1.3.0.
If you've tried it with the static version of PHP and got
the same results, please get back to us.
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 04:03:41 2021 UTC