php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44527 fgets Japanese translation
Submitted: 2008-03-25 06:03 UTC Modified: 2008-03-25 11:32 UTC
From: kentaro at ranvis dot com Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kentaro at ranvis dot com
New email:
PHP Version: OS:

 

 [2008-03-25 06:03 UTC] kentaro at ranvis dot com
Description:
------------
Japanese translation of fgets() is mistranslated.

Reproduce code:
---------------
http://jp2.php.net/manual/ja/function.fgets.php
The note in "length" parameter:

If the majority of the lines in the file are all larger than 8KB, it is more resource efficient for your script to specify the maximum line length.

Expected result:
----------------
ファイル内の行の多くが 8KB を超えている場合は、行の最大長を指定するとスクリプトのリソース効率がよくなります。

Actual result:
--------------
もしもファイル内の行の多くが 8KB を超えている場合、行の長さの最大値を特定するためにスクリプトはリソースの影響をより大きく受けることになります。

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-25 11:32 UTC] takagi@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

http://news.php.net/php.doc.ja/2280

You can see the result at the following URL (This page is updated every six hours). 

http://docs.php.net/manual/ja/function.fgets.php
 [2020-12-30 11:59 UTC] nikic@php.net
Automatic comment on behalf of takagi
Revision: http://git.php.net/?p=doc/ja.git;a=commit;h=82a00a9ce0407fec8ed691438a5b76097968e08e
Log: fixed bug #44527
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 07:03:34 2021 UTC