php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44372 Extension compile failed
Submitted: 2008-03-08 12:53 UTC Modified: 2008-03-12 04:37 UTC
From: petr at hroch dot info Assigned:
Status: Closed Package: OCI8 related
PHP Version: 5.3CVS-2008-03-08 (snap) OS: Linux Debian Etch 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: petr at hroch dot info
New email:
PHP Version: OS:

 

 [2008-03-08 12:53 UTC] petr at hroch dot info
Description:
------------
Extension compile failed using latest cvs snapshot

Actual result:
--------------
sit:/usr/install/src/oci8-1.3.1# make
/bin/sh /usr/install/src/oci8-1.3.1/libtool --mode=compile gcc  -I. -I/usr/install/src/oci8-1.3.1 -DPHP_ATOM_INC -I/usr/install/src/oci8-1.3.1/include -I/usr/install/src/oci8-1.3.1/main -I/usr/install/src/oci8-1.3.1 -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib -I/usr/local/oracle/home1/rdbms/public -I/usr/local/oracle/home1/rdbms/demo  -DHAVE_CONFIG_H  -g -O2   -c /usr/install/src/oci8-1.3.1/oci8.c -o oci8.lo
mkdir .libs
 gcc -I. -I/usr/install/src/oci8-1.3.1 -DPHP_ATOM_INC -I/usr/install/src/oci8-1.3.1/include -I/usr/install/src/oci8-1.3.1/main -I/usr/install/src/oci8-1.3.1 -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib -I/usr/local/oracle/home1/rdbms/public -I/usr/local/oracle/home1/rdbms/demo -DHAVE_CONFIG_H -g -O2 -c /usr/install/src/oci8-1.3.1/oci8.c  -fPIC -DPIC -o .libs/oci8.o
/usr/install/src/oci8-1.3.1/oci8.c: In function 'php_oci_do_connect_ex':
/usr/install/src/oci8-1.3.1/oci8.c:1150: warning: cast from pointer to integer of different size
/usr/install/src/oci8-1.3.1/oci8.c:1346: warning: cast to pointer from integer of different size
/usr/install/src/oci8-1.3.1/oci8.c: In function 'php_oci_connection_ping':
/usr/install/src/oci8-1.3.1/oci8.c:1381: error: too many arguments to function 'OCIPing'
make: *** [oci8.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-08 22:18 UTC] johannes@php.net
Pleas report issues with the pecl version on the pecl site. 
 [2008-03-10 23:36 UTC] sixd@php.net
Let me re-open this since I think I can guess what the problem is and will fix it.  Note to original poster: without any information about how you were building PHP, I can only hope my guess about your problem is right.
 [2008-03-11 12:38 UTC] petr at hroch dot info
This line oci8.c:1381: error: too many arguments to
function 'OCIPing' causes the problem.

I tryied to remove one argument from the OCIPing function arguments
than extension compiled successfully, but I'm only guessing.

Petr
 [2008-03-11 12:41 UTC] petr at hroch dot info
To your previous comment:

Extension was compiled externaly using phpize.

P.
 [2008-03-12 04:37 UTC] sixd@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


+------------------------------------------------------
| Fixed in PHP 5.3 & PHP 6.  Not fixed in 5.2, which wasn't affected.
+------------------------------------------------------
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 03:05:53 2022 UTC