php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #43743 Unicode Error Mode That Throws Exceptions On Error
Submitted: 2008-01-03 22:22 UTC Modified: 2018-05-05 19:25 UTC
From: geoffers at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 6CVS-2008-01-03 (CVS) OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: geoffers at gmail dot com
New email:
PHP Version: OS:

 

 [2008-01-03 22:22 UTC] geoffers at gmail dot com
Description:
------------
It would be useful to have a unicode error mode that threw exceptions on 
an error: this would make it possible to have different behaviour an 
error. Currently all that is possible is creating a custom error handler 
and acting differently depending on what the error string is: can an 
error string really be relied upon to never change? I doubt it.

What practical use, though? Most obviously, checking if a string is 
valid under a certain encoding. This is needed when processing real-
world XML data, due to the vast amount sent with the wrong encoding.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-05-05 19:25 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: Feature/Change Request +Package: *General Issues
 [2018-05-05 19:25 UTC] requinix@php.net
NAB due to insufficient quantities of PHP 6.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Fri Nov 16 11:01:25 2018 UTC