|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43571 php_admin* directive ignored
Submitted: 2007-12-11 23:35 UTC Modified: 2008-07-11 21:30 UTC
From: barbara at rfx dot it Assigned:
Status: Wont fix Package: Safe Mode/open_basedir
PHP Version: 4.4.7 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
45 + 20 = ?
Subscribe to this entry?

 [2007-12-11 23:35 UTC] barbara at rfx dot it
Basically the php_admin_value and php_admin_flag directive in VirtualHost httpd.conf (included) are ignored. Also in .htaccess
tried with safe_mode, open_dir, sendmail_path parameters.

Trustix 2.2 distro
Kernel 2.4.34
php 4.4.7
Apache 2.0.59

Same compilation options.
Until version 4.4.4 works, next version (now trying 4.4.7), not work.
Restoring php 4.4.4 still work.
Enabled/disabled Zend,mod_security, ...

Regards, B.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-12 10:41 UTC] andretta at apf dot it
Same problem here (using original Trustix src.rpm).

Solved rebuilding the rpm without the Console_Getopt patch.

Install php4 source rpm:
rpm -ivh php4.4.7*.src.rpm

edit the php4.spec (comments row referring the Console_Getopt patch)

rpmbuild -ba php4.spec

rpm -Fvh php4*

Done. :-)

Paolo Andretta
 [2008-07-11 21:30 UTC]
We are sorry, but we can not support PHP 4 related problems anymore.
Momentum is gathering for PHP 6, and we think supporting PHP 4 will
lead to a waste of resources which we want to put into getting PHP 6

PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Dec 04 02:05:53 2022 UTC