php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43127 Paging on searchresults doesn't make sense
Submitted: 2007-10-29 13:24 UTC Modified: 2007-10-29 22:20 UTC
Votes:2
Avg. Score:1.5 ± 0.5
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: harrie at ibuildings dot nl Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2007-10-29 13:24 UTC] harrie at ibuildings dot nl
Description:
------------
When searching the 'entire site' I get 'Showing results 1 to 10 of 38', on page 2 this changes in 'Showing results 11 to 17 of 40', on page 3 this changes again in 'Showing results 21 to 26 of 40'. Also, the number of results on a page and the number of pages changes. There seems to be a problem with splitting the searchresults in multiple pages.

Reproduce code:
---------------
Go to:

http://nl2.php.net/results.php?q=not+equal&l=nl&p=wholesite

Click on the page numbers and watch the number of results on the different pages.

Expected result:
----------------
10 results per page, total number of results and pages not changing while navigating to different pages.

Actual result:
--------------
Random (?) number of results per page, changing total results and pages

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-29 22:20 UTC] nlopess@php.net
we just display yahoo data. so if something is not right, it's not really our fault..
anyway it's not a big problem.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 15:01:26 2019 UTC