php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43122 fatal error on a strange causes
Submitted: 2007-10-29 04:29 UTC Modified: 2007-10-29 14:30 UTC
From: gabri dot ns at googlemail dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.4 OS: Windows 98/XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gabri dot ns at googlemail dot com
New email:
PHP Version: OS:

 

 [2007-10-29 04:29 UTC] gabri dot ns at googlemail dot com
Description:
------------
Actually it isn't an IIS error, but ISAPI related.
I'm using Abyss Web Server 2.x and PHP 5.2.x on ISAPI interface.
This error doesn't exist when using CGI.

Don't ask me to change the interface to CGI.
I have tried it, but since I using low memory computer
it can't be done.

Thank's before.

Reproduce code:
---------------
<?php

function redirect($page = 'page')
{
	header('Location: '.$_SERVER['PHP_SELF']);
	exit();
}
redirect();

?>

Expected result:
----------------
infinite loop of redirecting

Actual result:
--------------
Fatal error: Cannot redeclare redirect() (previously declared in G:\Gbr\AbyssWS\htdocs\crash.php:3) in G:\Gbr\AbyssWS\htdocs\crash.php on line 3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-29 14:30 UTC] jani@php.net
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
 
Thanks for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 14 16:01:28 2024 UTC