php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42079 pdo_mysql always links to 3.x libraries (== PDO* in HEAD is out-dated)
Submitted: 2007-07-23 11:30 UTC Modified: 2008-09-12 23:06 UTC
Votes:6
Avg. Score:3.3 ± 1.4
Reproduced:6 of 6 (100.0%)
Same Version:5 (83.3%)
Same OS:4 (66.7%)
From: mjsabby at gmail dot com Assigned:
Status: Closed Package: PDO related
PHP Version: 6CVS-2007-07-23 (CVS) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mjsabby at gmail dot com
New email:
PHP Version: OS:

 

 [2007-07-23 11:30 UTC] mjsabby at gmail dot com
Description:
------------
In PHP6 CVS, the PDO driver for MySQL always uses the MySQL 3.x client API version, according to phpinfo()

From what it looks like, phpinfo() is telling the truth here, a connect to the DB failed because of password incompatibility, probably suggesting the client API is 3.x

However, I could very well be wrong, and it may just be a phpinfo() output error.

I've compiled 5.2.3 with the same config line (plus/minus ICU) and that works as desired.

PHP 6 config line:
'./configure' '--with-apxs2=/usr/local/apache2/bin/apxs' /
'--with-mysql=/usr/local/mysql' /
'--with-mysqli=/usr/local/mysql/bin/mysql_config' /
'--with-pdo-mysql=/usr/local/mysql' --with-icu-dir='/home/mukul/icu'

PHP 5.2.3 config line:
'./configure' '--with-apxs2=/usr/local/apache2/bin/apxs' /
'--with-mysql=/usr/local/mysql' /
'--with-mysqli=/usr/local/mysql/bin/mysql_config' /
'--with-pdo-mysql=/usr/local/mysql'

PHP 5.2.3 screen: http://mjsabby.com/pdo523.jpg
PHP CVS6 screen: http://mjsabby.com/phpcvs6.jpg

Expected result:
----------------
PHP 6 should (or if it's a phpinfo() error, then display) the correct MySQL client API that the PDO has been enabled with.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-02 21:41 UTC] jani@php.net
This is not really any bug, just the fact that CVS HEAD (aka PHP 6) has very outdated PDO* sources. It's really linked with whatever libs you have. Hopefully someone gets around to syncing the sources from PHP_5_x branch where they're up-to-date.
 [2008-09-12 23:06 UTC] johannes@php.net
PDO_MYSQL in HEAD is the same as PHP_5_3 for a few weeks now
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 14:03:37 2021 UTC