php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41974 xpath query searchs only first attributes
Submitted: 2007-07-12 00:12 UTC Modified: 2007-07-12 22:46 UTC
From: netdur at gmail dot com Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 5.2.3 OS: Ubuntu
Private report: No CVE-ID: None
 [2007-07-12 00:12 UTC] netdur at gmail dot com
Description:
------------
let's say we have XML document has line that looks like this

<elem attr="_str_"/>

using xpath query "//*[contains (@*, 'str')]" will find that element, however if that XML line looks like this

<elem id="123" attr="_str_"/>

xpath will fail finding the element!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-07-12 11:51 UTC] rrichards@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Output is correct. read up on the conversion of nodesets to strings in the xpath specs
 [2007-07-12 22:46 UTC] netdur at gmail dot com
yes right! my mistake... a follow (for Googlers) http://mail.gnome.org/archives/xml/2007-July/msg00024.html
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 00:01:24 2020 UTC