php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41671 socket_select() and invalid arguments
Submitted: 2007-06-12 12:40 UTC Modified: 2007-06-25 19:08 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: darksport at interzet dot ru Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.4.7 OS: gentoo linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: darksport at interzet dot ru
New email:
PHP Version: OS:

 

 [2007-06-12 12:40 UTC] darksport at interzet dot ru
Description:
------------
I've wrote an ftp class which provides some major functions from ftp extension. I couldn't use ftp functions in my scripts because it was important for me to handle files larger than 2gb and i needed to catch the protocol debug information on errors.
I have a problem with sendCommand() function, because socket_select() function returns error: "Warning: socket_select() no resource arrays were passed to select". When i comment out socket_select() from my function - everything works as expected.

Reproduce code:
---------------
You can find my class here: http://interzet.ru/ftp.class.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-25 19:08 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 09:03:33 2022 UTC