php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40595 IMAP extension: utf8_mime2text() has wrong parameters
Submitted: 2007-02-22 18:26 UTC Modified: 2007-02-22 23:33 UTC
From: perske at uni-muenster dot de Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5.2.1 OS: AIX
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: perske at uni-muenster dot de
New email:
PHP Version: OS:

 

 [2007-02-22 18:26 UTC] perske at uni-muenster dot de
Description:
------------
Bug 37948 should be reopened:

The bugfix assumes that U8T_CANONICAL is not defined
when the old parameter count of utf8_mime2text() is
valid.

But with the current imap2006e.tar.Z, U8T_CANONICAL is
defined and utf8_mime2text() takes only two parameters.
Thus configure fails with "this cannot happen".

Supposed correction: Simple do not check for existence of
U8T_CANONICAL in configure if the old parameter count
is detected.

(I'm trying to compile PHP 5.2.1 with imap2006e.)

(After replacing all U8T_CANONICAL with XYXYXY in
configure, compilation finishes successful.)

Reproduce code:
---------------
n/a

Expected result:
----------------
n/a

Actual result:
--------------
n/a

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-22 18:55 UTC] tony2001@php.net
>But with the current imap2006e.tar.Z, U8T_CANONICAL is
>defined and utf8_mime2text() takes only two parameters.

That's not true.
See imap-2006e/src/c-client/utf8aux.c, line 116:
long utf8_mime2text (SIZEDTEXT *src,SIZEDTEXT *dst,long flags)

 [2007-02-22 23:33 UTC] perske at uni-muenster dot de
Sorry! My mistake! configure detected this wrong.
Because my system (AIX with IBM compiler) is explicitly
unsupported, this is not a bug of PHP.

(When checking for utf8_mime2text signature, compiling with
"cc_r -c -I/www/imap/include conftest.c" ended with exit
code zero although there was an error message. This misdirectored configure that only looks at the exit code, and misdirected me, too. Please apologize.)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 21:03:42 2021 UTC