php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39452 image_type_to_extension returns jpeg instead of jpg
Submitted: 2006-11-09 16:32 UTC Modified: 2006-11-13 09:14 UTC
From: datenpunk@php.net Assigned:
Status: Not a bug Package: GetImageSize related
PHP Version: 5.2.0 OS: Debian
Private report: No CVE-ID: None
 [2006-11-09 16:32 UTC] datenpunk@php.net
Description:
------------
Hello,

this may be no bug or bogus but I just switched over to 5.2 and broke some apps because image_type_to_extension returns '.jpeg' instead of '.jpg'.
I think that '.jpg' would be the right choice for an extension.

Greetings

-- 
Daniel KHan


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-09 16:50 UTC] tony2001@php.net
image_type_to_extension() has been _enabled in 5.2.0_, are you sure you were using the same function before?
 [2006-11-12 22:57 UTC] datenpunk@php.net
Sigh! - Sorry. I used a workaround posted at php.net. It uses !function_exists('image_type_to_extension') to determine if the php function exists...

Shame on me! I'm sorry!
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Apr 24 02:01:25 2019 UTC