php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39084 string casting and comparison with ==
Submitted: 2006-10-08 23:46 UTC Modified: 2006-10-09 09:50 UTC
From: stevebird at gmx dot de Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.1.6 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: stevebird at gmx dot de
New email:
PHP Version: OS:

 

 [2006-10-08 23:46 UTC] stevebird at gmx dot de
Description:
------------
string casting and comparison with ==

with === it is ok, but both types are strings

Reproduce code:
---------------
if ( (string)'0X2BAD' == (string)'11181' ) {
echo "php sucks";
} else {
echo "php is ok";
}

Expected result:
----------------
php is ok

Actual result:
--------------
php sucks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-09 09:50 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Feb 20 21:01:25 2019 UTC